I am installing oracle database in Ubuntu 16.04. I unzipped the file in /opt, then I tried to create a symbolic link using

sudo ln -s /opt/sqldeveloper/sqldeveloper.sh/usr/local/bin/sqldeveloper

but it shows error

ln: failed to create symbolic link './sqldeveloper': File exists

What should I do?

  • 2
    Typo? I think you intended to run sudo ln -s /opt/sqldeveloper/sqldeveloper.sh /usr/local/bin/sqldeveloper?. – Thomas Oct 31 '17 at 9:03
  • yes,I ran the command given in the question above. – Prashant Mani Oct 31 '17 at 9:06
  • although the code given by Thomas did worked but I really want to how is it different from that of my code given in question,coz I really can't find any difference – Prashant Mani Oct 31 '17 at 9:13
  • The difference is a space. – user692175 Nov 4 '17 at 3:41

There is space missing in your command. Use this command (also mention by Thomas in comment).

sudo ln -s /opt/sqldeveloper/sqldeveloper.sh /usr/local/bin/sqldeveloper

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.