3

ubuntu 17.10, kubuntu 17.10, ubuntu server 17.10

From newly installed virtual machines with 17.10, when pinging some devices in my local network there is a problem with name resolution. Pinging the IP address works. But pinging them by their hostname does not always work. I can ping by name between the new linux VMs, as well Windows machines, but pinging by name older linux devices, e.g. router, leads to the message :"Temporary failure in name resolution". That problem does not exist when pinging from VMs with older Linux installations. Something that affects name resolution must have changed in the 17.10 versions. (the problem is not ping, it is name resolution) Can anybody confirm this or help figure out what the reason is? Can this be considered a bug?

  • I have the same problem on my Ubuntu laptop. Name resolution doesn't work. It happened out of the blue a few hours ago and still exists. – vahid-dan Oct 31 '17 at 21:47
0

I downloaded Ubuntu 17.10 and ran it from RAM to test. Worked OK. I installed 17.10 on drive.

Installed couldn't reach the net:

"Temporary failure in name resolution".

A few days of fruitless "fixes" led to the discovery that in my 17.10, /etc/resov.conf was a link of /run/systemd/resolve/stub-resolv.conf. But /run/systemd/resolve did not exist (I think [most of] "run" is populated at boot time).

I rebooted the ram version and found that resolv.conf contained (unique to my installation):

# Generated by NetworkManager

search fios-router.home

nameserver 192.168.1.1

Put this my installed resolv.conf. Problem solved.

0

I've experienced it after upgrading (server edition) from 16.04 to 18.04, and apparently solution was to disable systemd-resolved as:

sudo systemctl disable systemd-resolved

and then reboot

sudo reboot

I found info about that here: https://ubuntuforums.org/showthread.php?t=2391351&s=adb88d3358fcc695b8480334fcbe2ba9&p=13765197#post13765197

It appears that on server edition, systemd-resolved is conflicting with netplan.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.