1

I upgraded 17.04 to 17.10 and now cannot use the <alt> shortcuts in firefox anymore. Pressing <alt> and releasing it opens the firefox menu, but pressing for example <alt>Left does not go back the history and firefox looses focus.

I have been looking through many posts that seem to be related:

  1. removed the HUD launch from unity from it (though in unity it used to work properly)

  2. tried to remove the <alt> overlayKey, after looking at the conflict described https://github.com/lestcape/Gnome-Global-AppMenu/issues/51

  3. tried to disable the menu bar toggle as in http://bsriram.info/2015/04/07/disable-menu-bar-toggle-in-firefox/, but that didn't seem to work.

I don't know if any of these is actually related, but I really want my <alt> shortcuts back in firefox.

0

Okay, I got it solved (very easily in the end!), following https://github.com/lestcape/Gnome-Global-AppMenu/pull/50#issuecomment-317187954 :

  • Right click inside the menu
  • In the popup menu left click in configure...
  • Scroll to the box Main Menu
  • Click inside the "Alt" shortcut, in the option keyboard shortcut to open and close the menu
  • Hit Backspace key (to delete the current shortcut).

This changes the overlayKey globally, so it also makes the shortcuts for example in nautilus also working again.

  • Gnome not have a real way to define a modiefier as a keybinding for extensions (or i don't know how do it). Also they are not sending any signal for a key-release event, just only for a key-press. If we want to use a modifier keybinding, it need to be capture as a key-relase event, to not interfer with others keybinding. My work-around, is set the focus to the shell, to be possible handled the key-release event, but this remove the focus to the application and then if the application have a keybinding will not be capture, as the application window have not the focus. – lestcape Nov 2 '17 at 23:17
  • You can use another shortcut (instead of backespace it hit the new shortcut), you don't need to delete it, at less in Xorg. In Wayland the global menu don't work. Sorry if that cause some problem to you. I hope the Gnome developers find a way to be more general and allow to have a better keybinding manager... We not need inventions like that. – lestcape Nov 2 '17 at 23:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.