0

I'm working on installing sage, and I now just need to run the "make" command in the command line, but when I do I get the following:

/usr/bin/env: 'python': No such file or directory

Makefile:16: recipe for target 'all' failed

make: *** [all] Error 127

My python is installed in

usr/bin/python3.6m

usr/bin/python3.6

usr/bin/python2.7

Or at least that's what I find when I run:

find /usr -type f -name 'python*' -perm -a+x

Update: I ran "sudo apt-get install python" and ran "make" and had a huge list of outputs, then ran ./sage, which crashed very quickly.

4
  • 1
    What python is in your $PATH? type -a python Oct 30, 2017 at 20:37
  • @glennjackman it is in usr/bin/python
    – Ammastaro
    Oct 31, 2017 at 14:13
  • If you do ls -l /usr/bin/python is it a symlink to python2 or python3? Oct 31, 2017 at 14:22
  • It says python2.7
    – Ammastaro
    Oct 31, 2017 at 14:36

1 Answer 1

1

It seems this requires python2, but not a specific version of it to execute. You need to have the python-minimal package installed, as it is what provides the /usr/bin/python symlink.

1
  • I've already had that installed
    – Ammastaro
    Oct 30, 2017 at 20:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .