0

I am having this issue with new Ubuntu installation on one of my friends. I am trying to access his laptop and I cannot access from my laptop. Previously it was working perfectly and I can connect to other friends but not with this one. He is running Ubuntu 16.04 LTS and installed Teamviewer using .deb package.

When I enter his user ID, it simply throws a pop up with:

`Connection could not be established.

Reason Unknown error `

I searched on the web, but it didn't have proper answer. Can any one help me with this on Ubuntu?

  • Have you checked to see if the daemon i runnimg? gksu "systemctl start teamviewerd" – jpezz Oct 30 '17 at 19:48
  • Yes, I guess without it running he cannot launch the TeamViewer GUI I believe. His GUI is open as usual and I got his User ID then I was trying to connect to his laptop. – Piyush Patel Oct 31 '17 at 2:35
  • I'd try and disable his computer's firewall temporarily. Don't leave it that way if it fixes the problem (if it was on in the first place) but check the settings if it does fix it. – jpezz Oct 31 '17 at 14:40
  • @Plyush P, the GUI does come up but warns you the service is not running. I have disabled the service on my system and have a Desktop link to start it up before running the GUI. – jpezz Oct 31 '17 at 18:48
  • Oh you tried it with stopped teamviewerd??? Because on the same system that I have with the same OS and same version of Teamviewer, I tried to stop using systemctl stop teamviewerd and that actually stopped my GUI program too. I will try your suggestion too. I am not sure about his system. I have searched and I found a forum suggesting to disabled UDP in Teamviewer settings, but it didn't work for me. – Piyush Patel Oct 31 '17 at 18:58
0

I leave mine stopped so when I log in, I see no daemon running. i.e. ps -ef|grep -i teamviewer shows no teamviewer processes. systemctl gksu start teamviewerd is a Desktop Icon to start it. If I try to run Teamviewer from the gui before starting the daemon, I get a popup that says

"The teamviewer daemon is not running. Please start the daemon (needs root permission) ..."

0

I had the same problem. After searching on the net, I found a hint that it is a time problem at startup. I edited the file /etc/systemd/system/teamviewerd.service by adding a sleep in the ExecStart line:

ExecStart = /bin/bash -c "sleep 60; /opt/teamviewer/tv_bin/teamviewerd -d"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.