0

I followed the top post off of this question What to do when I get an "attempt to read or write outside of disk 'hd0'" error and Boot Repair does not solve the problem? . After typing these two steps after finding filetype ext 2 or something similar on hd0,msdos5

grub rescue > set root=(hd0,msdos5)

grub rescue > set prefix=(hd0,msdos5)/boot/grub

I was unable to do anything else. After restarting I now get "Reboot and select proper boot device". From here I can see in my BIOS that my hard drive is not being detected. I tried unplugging and replugging the cables and same response on boot "Reboot and select proper boot device". I've launched Ubuntu on a live USB and tried to install boot repair but get no option to repair boot. Here is my paste bin http://paste.ubuntu.com/25853215/

From this point I have no idea what to do other than buy a new hardrive. I have a 2 terrabyte seagate drive that I was dual booting ubuntu and windows on. My machine crashed when I was playing a game on windows. Any help would be greatly appreciated.

  • Your hard drive is not recognized, is it working ? Or are you looking at hard drive failure ? All I see in your boot-repair output is your flash drive with the live image. Try fdisk, testdisk, etc. Identify hardware. – Panther Oct 30 '17 at 19:35
  • When using fdisk and testdisk, neither show that I have a hard drive connected and only show the USB memory. using dmidecode -q , I saw multiple sections of Memory Device { Size: No Module Installed, Type: Unknown, Data Width: 64 bits} (those were just some of the key value pairs listed under multiple sections of Memory Device) I guess I'm looking at hard drive failure? It was working fine playing Overwatch and then froze up on me. I don't really have any data I need saved, but I have no other computer to check and see if the hard drive has failed – Khaladin Oct 30 '17 at 20:55
  • Sounds like hard drive failure. The only other possibility would be a loose connection. Open the box, check the connections, and see if you "bios" detects the drive. If not, l think you need to look for a replacement drive. – Panther Oct 30 '17 at 21:01
  • Thanks for your time, It's just weird because I was originally in the grub rescue prompt before I used those two commands. That leads me to believe that it was accessing the partition with Ubuntu on it because that's the partition GRUB was installed on. – Khaladin Oct 30 '17 at 21:05
  • It is strange, hard to say unless you can access the drive for diagnostics . – Panther Oct 30 '17 at 21:10

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.