37

I recently upgraded to ubuntu 17.10 and since then I cannot do two finger scrolling, only edge scrolling. Any suggestions how to make the two finger scrolling work again? I use a Lenovo ThinkPad 450s


Output of xinput list-props $(xinput list | perl -ne '/touchpad.*\bid=(\d*)/i && print $1') as requested by @Hi-Angel

Device 'SynPS/2 Synaptics TouchPad':
Device Enabled (141):   1
Coordinate Transformation Matrix (143): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
libinput Tapping Enabled (276): 1
libinput Tapping Enabled Default (277): 0
libinput Tapping Drag Enabled (278):    1
libinput Tapping Drag Enabled Default (279):    1
libinput Tapping Drag Lock Enabled (280):   0
libinput Tapping Drag Lock Enabled Default (281):   0
libinput Tapping Button Mapping Enabled (282):  1, 0
libinput Tapping Button Mapping Default (283):  1, 0
libinput Accel Speed (284): 0.600000
libinput Accel Speed Default (285): 0.000000
libinput Natural Scrolling Enabled (286):   1
libinput Natural Scrolling Enabled Default (287):   0
libinput Send Events Modes Available (261): 1, 1
libinput Send Events Mode Enabled (262):    0, 0
libinput Send Events Mode Enabled Default (263):    0, 0
libinput Left Handed Enabled (288): 0
libinput Left Handed Enabled Default (289): 0
libinput Scroll Methods Available (290):    1, 1, 0
libinput Scroll Method Enabled (291):   0, 1, 0
libinput Scroll Method Enabled Default (292):   1, 0, 0
libinput Click Methods Available (293): 1, 1
libinput Click Method Enabled (294):    1, 0
libinput Click Method Enabled Default (295):    1, 0
libinput Middle Emulation Enabled (296):    0
libinput Middle Emulation Enabled Default (297):    0
libinput Disable While Typing Enabled (298):    1
libinput Disable While Typing Enabled Default (299):    1
Device Node (264):  "/dev/input/event5"
Device Product ID (265):    2, 7
libinput Drag Lock Buttons (300):   <no items>
libinput Horizontal Scroll Enabled (301):   1
83

The answer here by @hpotter40 worked for me:

$ sudo modprobe -r psmouse
$ sudo modprobe psmouse

This was taken from comment #16 of this bug report: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1722478/comments/16


Update for a more persistent solution:

Based on comment #44 and #45 of the same bug report above, this should also work. Open the file /etc/default/grub and edit the value of the GRUB_CMDLINE_LINUX_DEFAULT variable. By default this has the value of "quiet splash". The value "psmouse.synaptics_intertouch=0" could be added to it so that it becomes like:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash psmouse.synaptics_intertouch=0"

Then update GRUB by executing:

$ sudo update-grub

Reboot your system and this setting should survive even after suspends. As a note, all these answers are simply workarounds until the kernel error could be identified and patched.

| improve this answer | |
  • 2
    This works for me, but every time my computer goes to sleep I have to rerun this again and again. – weberc2 Mar 10 '18 at 23:18
  • Same here... it works but have to rerun after sleep (I'm actually still on 16.04 though). – senorsmile May 9 '18 at 0:26
  • doesn't work for me, two fingers still doesn't scrolling, it seems like restarting mouse functionality – Khaled AbuShqear Apr 25 '19 at 19:48
  • 1
    Anyone got a lasting fix for this? Is there any .*rc file or something that runs after waking from sleep that we could put these commands in? – Robin Winslow Nov 6 '19 at 9:38
  • 3
    Persistent fix: add psmouse.synaptics_intertouch=0 to your grub config. See bugs.launchpad.net/ubuntu/+source/linux/+bug/1722478/comments/… – user4780495 Nov 27 '19 at 20:16
6

You can enable two finger scroll by clicking System Settings > Mouse & Touchpad. You will see a window like this enter image description here

You can (un)check the check box according to your preference.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.