1

I have installed VMware horizon client and virtual box and running windows OS as guest OS in both of them. When I used windows + D or alt+tab in the guest os in fullscreen mode, the apps are switching on Ubuntu instead my guest OS. Those apps worked fine on 17.04

  • I didn't work with vmware, but I'm pretty sure there's somewhere a checkbox to intercept host os keys. Unless vmware itself broke something, it can not stop working due to external circumstances — there's a design decision in Xorg to allow a definite shortcut interception, which many peoples do not like by the way. – Hi-Angel Oct 30 '17 at 22:55
  • 1
    I don't see any option in vmware. Virtual box has that option and it is not working on virtual box as well. Short cut keys worked fine on ubuntu 17.04. The problem occurred after the ubuntu upgrade to 17.10. – Amar Reddy Oct 31 '17 at 8:16
1

It's a Wayland problem. In the Ubuntu login screen you can choose X11. Than it should work again.

  • Unfortunately this is not a proper solution. I have the same problem - Ubuntu 17.10 with wayland and I can't use Alt+tab for switching windows inside the VMware Horizon view client. And this can't be just "wayland issue" as it works in Fedora 27 which use wayland as well. So it looks like this is a problem with implementation of wayland in Ubuntu 17.10. – user241281 Jan 22 '18 at 21:08
  • Not only on Ubuntu : bugzilla.redhat.com/show_bug.cgi?id=1285770 – r03 Jan 23 '18 at 5:54
  • Looks like it is fixed in wayland now: lists.freedesktop.org/archives/wayland-devel/2017-July/… – r03 Jan 23 '18 at 6:16
  • Well, I checked what version of wayland-protocols do I have in my Ubuntu 17.10, but there was no such package installed. So I installed it. It is version 1.10-1. After installation the shortcut keys still do not work in WMware Horizon Client. I did not restart or logout/login yet. – user241281 Jan 23 '18 at 9:50
  • Even after installing wayland-protocols version 1.10-1 and rebooting PC, I still can't use keyboard shortcuts in WMware horizon client. And I tried not also in Virtualbox - it has the same issue, for instance I can't use alt+tab for switching windows in guest OS :( . – user241281 Jan 23 '18 at 10:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.