4

I'm on Ubuntu 17.10 with GNOME 3.26.

Often I have windows tiled on the left and right side of the screen. A typical setup is to have a browser and text editor on the left, a PDF reader and terminal on the right.

Something I've seen happen very often: I'm reading the PDF on the right, having the window in focus. The text editor on the left. When I click on the text editor to write something, it brings forward another window on the right (say the file browser), covering the PDF reader.

This seems to have something to do with the Alt-Tab view history.

My question is: Is it possible to remove the automatic bring-to-front of windows? I don't understand why unrelated windows are brought to the front when I click on another application.

  • 1
    If this is happening, it is definitely not normal behavior, and is a bug. I'd recommend recording a short video to demonstrate the issue, and perhaps opening a bug. If you do record the video, please edit your question and include a link to it. – dobey Oct 30 '17 at 16:21
7

I was puzzled by the same behavior in Fedora 27 / GNOME 3.26.

I found that GNOME 3.26 introduced a new feature which implicitly groups tiled windows and raises the entire group when one receives focus:

  • Tiled windows that are not complementary sizes are not in the same T-Group
  • When resizing, they join a T-Group if their borders match
  • Resizing to screen borders change to maximized
  • Keyboard tiling always join T-Groups
  • When raising a window in a T-Group, the entire group is raised as well

Unfortunately, this grouping behavior is implicit, and the only way to break grouping in 3.26 is:

It is still possible to break tiled windows grouping by simply untiling the window with the keyboard or by grabbing and resizing or moving the window with the cursor.

However, this means you have to give up the convenience of tiling if you don't want windows to be grouped.

This new feature is an annoyance for my workflow as well, at least there is a todo item listed on the feature page that is slated for GNOME 3.28:

  • Implement explicit group activation

-- UPDATE --

Per this comment in GNOME's bugzilla it appears that this behavior will be reverted in the next stable release.

| improve this answer | |
  • 1
    This "feature" really hampers productivity multiple times a day. Apparently a patch exists now: gitlab.gnome.org/GNOME/mutter/commit/415584344a5d4b5 Would be fantastic if a patch was provided for 17.10... – sxc731 Mar 6 '18 at 20:20
  • As indicated in the linked bugzilla thread, upgrading to GNOME 3.28 resolves the issue – mgilbert May 23 '18 at 21:56
1

I can't solve this problem with GNOME but I can suggest a workaround if you're willing to install the gtile extension (I am not affiliated with the developers). The extension was designed to support tiling modes other than just left/right split, but you can configure it to support such tiling as well. Windows resized by the extension don't seem to suffer from the issues caused by windows resized by GNOME itself.

Steps:

  1. Install the extension and clear the Super+left/Super+right keyboard shortcuts using the settings application.
  2. Use gnome tweak tool to change the settings for Gtile under the Extensions tab.
  3. Enter the accelerators tab and set the shortcut for Preset resize 20 to Super+left and Preset resize 30 to Super+right (I chose these because they aren't used by the extension by default).
  4. Enter the Resize presets tab and set Preset resize 20 to 2x2 0:0 0:1 and Preset resize 30 to 2x2 1:0 1:1.

Note: in my experience gtile has issues taking into account the space taken up by the dock, so it might resize windows to overlap with the dock. I keep the dock hidden to save space so it's not an issue for me, but for you it might be exchanging one annoyance for another, unfortunately.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.