13

In 17.10 I've looked in Settings->Privacy, Screen Lock is off. In Power Blank Screen is off. Yet after some minutes of inactivity the screen just doesn't turn off, a lock screen appears that needs the mouse to pull up.

This is a PC in my house, I'm really not concerned that one of the dogs could wander by and see my screen. Is there a way to really turn off this lock screen? Turning the display off after some minutes would be fine.

2
  • The same problem with my home media server on 17.10. Furthermore looks like Ubuntu do log out when i turn off TV.
    – rukeba
    Nov 11, 2017 at 19:23
  • possibly related: askubuntu.com/a/1011952/17060 . But if the problem is not related to the gnome3 screen curtain and instead related to turning off the display, then it's probably unrelated.
    – michael
    Mar 5, 2018 at 3:26

5 Answers 5

1

Post #10 here https://bbs.archlinux.org/viewtopic.php?id=171226 fixed it for me. I think I finally found a way to disable the inactivity curtain in gnome 3.10. Launch dconf-editor then drill down org > gnome > desktop> session. Find the key for idle-delay and change it's value to 0 .

Or you can do it in once step by running the command:

gsettings set org.gnome.desktop.session idle-delay 0

You'd think it would be easy to get rid of that annoying stuff...

2
  • Welll... this completely disables screen blanking, not just the curtain. I wouldn't mind the screen going blank and a mouse wiggle waking it up. But this is better than the curtain, so thanks!!
    – LarryM
    Mar 3, 2018 at 16:24
  • +1 for the idea of changing settings in dconf-editor. The settings I changed were different ones e.g. /org/gnome/desktop/screensaver/lock-enabled, /org/gnome/desktop/screensaver/ubuntu-lock-on-suspend and /org/gnome/desktop/lockdown/disable-lock-screen (I am a bit confused by the double-negative here, but I decided to set it to 'on')
    – craq
    Jun 19, 2018 at 0:15
1

Same problem in 18.04. So, I tested a bit. Despite disabling all settings of screensaver and lock screen, the lock screen was still active. But there is a solution. Turns out, the "gnome-screensaver" is still active in the background. Removing it (apt-get remove gnome-screensaver) does the trick. Now you can even enable the screensaver again and it won't lock the screen anymore ;)

11
  • Hmm, I tried to remove it and got the message: Package 'gnome-screensaver' is not installed, so not removed I am also on 18.04 now.
    – LarryM
    May 16, 2018 at 16:06
  • 1
    Interesting. Ok, seems you are having intense difficulty with this particular problem. So, let me go deeper on what I did. First of all, are you using Ubuntu? Secondly, which GUI/WM are you using? I'm using Mate. This started with the problem of not being able to login at the lock screen. So, first thing I did, was disable the lock screen (control center, screensaver). But since the 18.04 upgrade it just ignored that setting. So, first of all I went down to 1 minute for the screensaver setting for testing. Next I disabled the screensaver. Didn't help.
    – Neobie
    May 18, 2018 at 1:13
  • 1
    Next I went to the startup applications and did the same. Also rebooting the PC. Now guess what. The lock screen was still there. Blue screen, black panel on top. Here is something interesting: it came after the minute for the screensaver. So, some online pages suggested the privacy settings. Which I couldn't find in Mate. So, here is a trick, newer users don't seem to know. Do NOT disable the lock screen, once it's there. Instead, switch to a text mode login. And it seems, this is fairly unknown among new users. Just hit crtl+alt+2 (3,4,5 or 6. 7 will get you back to the GUI).
    – Neobie
    May 18, 2018 at 1:14
  • 1
    What you should see now, is a black screen with a login in white. Log in with your user. And now you can check for running processes. I would suggest particular strings like "screen" and "lock". So, ps -e | grep -i "screen" and/or ps -e | grep -i "lock". This way I've been able to find the problem on my end. After that, removing was just a shot. But that did it for me. Log out, go back to the GUI and reactivate the screensaver. And maybe go up from one minute. That's what I did. I suggest you try the same. Instead of just trying this and that, try to find the cause of the problem.
    – Neobie
    May 18, 2018 at 1:14
  • And as mentioned, I would suggest the process list to find it.
    – Neobie
    May 18, 2018 at 1:14
1

In 17.10, I finally found that the entering Settings (top-right corner, then click the wrench in the drop-down), then changing Power -> Dim screen when inactive to OFF as well as Blank screen to Never worked.

I can't imagine what kind of thought process went into hiding these settings so far away in unintuitive locations would be a good idea, but that's what we're stuck with as a terrible default.

2
  • 1
    Thanks for contributing to Ask Ubuntu! But you're supposed to find settings in, well.. Settings! I don't think an icon in the Application Launcher is really hard to launch May 28, 2018 at 23:44
  • Won't work in 18.04 and it makes sense to dim the screen.
    – empedokles
    Sep 30, 2018 at 16:53
0

In my 17.04, there seems to be two places that involve lock:

Settings - Privacy

Settings - Brightness & Lock

That what you have in 17.10? If so, check that Brightness & Lock show Lock being OFF.

4
  • 1
    No, the settings screens are different between 17.04 and 17.10. There is no "Brightness & Lock" to turn off.
    – LarryM
    Nov 6, 2017 at 21:48
  • 2
    In 17.10: Settings > Power > Blank Screen > "Never" ... this and Setting > Privacy > Screen Lock > "Off" avoids the "pull me up I don't make any sense" screen
    – Rocjoe
    Dec 6, 2017 at 18:18
  • @Rocjoe That didn't work for me Jan 18, 2018 at 19:13
  • Yes turning the "blank screen" off works. But when I leave the computer for 15 mins, I want the monitor to go dark.
    – user372194
    Mar 7, 2018 at 18:20
0

Get rid of the annoying "pull me up I don't make any sense" screen shield in GNOME 3

https://extensions.gnome.org/extension/672/disable-screen-shield/

3
  • 1
    Sadly this doesn't remove the screen shield in 17.10
    – LarryM
    Nov 1, 2017 at 2:54
  • Is there no hope then???
    – LarryM
    Nov 3, 2017 at 2:46
  • One can just type their password into the (seemingly useless) screen curtain, and it'll unlock the screen just as if you were typing into the screen lock password field.
    – michael
    Mar 5, 2018 at 3:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.