2

When I run journalctl -xe as a non-root user, I get the following error:

bgeron@machine:~$ journalctl -xe
Failed to search journal ACL: Operation not supported
No journal files were opened due to insufficient permissions.
2

This can be caused by mounting ZFS with the wrong options. Journald requires access control lists, which are off by default in ZFS on Linux.

To enable access control lists, you must set the acltype=posixacl property on your filesystems. According to the zfs(8) man page, it is also recommended to set the xattr=sa property, which is more efficient, but only supported by "relatively new" ZFS implementations.

Set the properties as follows, for each filesystem:

zfs set acltype=posixacl poolname/path/to/fs && zfs set xattr=sa poolname/path/to/fs

After setting these properties, restart journald:

sudo systemctl restart systemd-journald

See also: https://github.com/NixOS/nixpkgs/issues/16954

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.