After upgrading to Ubuntu 17.10 from 17.04, I have been unable to launch gnome-terminal.
Upon clicking terminal icon, the taskbar shows terminal loading bar but then disappears after a few seconds.

Terminal loading in the taskbar:


I have tried the following:

  • Purged and Re-installed gnome-terminal
  • sudo apt-get autoremove and fix-missing
  • Changed locale to en_US in /etc/default/locale

I am able to access xterm and running gnome-terminal returns the following:

No protocol specified  
Unable to init server: Could not connect:
Connection refused   
Failed to parse arguments: Cannot open display:

Searching the error gives results solving terminal access issues over an ssh connection which is not my case.

How do I fix this and get gnome-terminal running?

  • 1
    A work-around is to install another terminal emulator. There are many, that are on par with gnome-terminal. Some are lighter, some are more powerful. Do you want tips about suitable candidates?
    – sudodus
    Oct 30, 2017 at 11:47
  • @sudodus Yeah sure! Xterm doesn't let me use copy-paste shortcuts. Anything that does will be handy Oct 30, 2017 at 11:53
  • lxterminal and sakura are light, xfce4-terminal is medium (comes with Xubuntu), tilda has special features ..., I have read about terminator but not used it. -- But you can mark and paste with xterm according to this link, askubuntu.com/questions/961175/…
    – sudodus
    Oct 30, 2017 at 12:04
  • 1
    I have installed Terminator which works good. It does support copy-paste . Thanks for the suggestions. @sudodus Oct 30, 2017 at 12:11
  • I think you might stay with terminator :-)
    – sudodus
    Oct 30, 2017 at 12:16

2 Answers 2


I has the same problem but with file-roller and follow this solution.

You have to change this file /etc/ssh/sshd_config (with root permissions). Just add

X11Forwarding yes

After saving the file, initialize a new terminal or reboot the system.

  • 2
    I tried this method and reinstalled gnome-terminal. Checked sshd_config and it already has X11Forwarding set as yes. So the solution doesn't work for me. I guess I will just continue using terminator for now. Thank you for your answer @Santoja . If the answer does help someone, let me know, I will accept the answer. Oct 31, 2017 at 6:21

If you have installed new python 3.5 env you are unable to open gnome-terminal. Use the following commands:

  1. sudo rm /usr/bin/python3
  2. sudo ln -s python3.5 /usr/bin/python3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.