Followed Brother MFC-L2700DW printer does not work to install the printer/scanner driver

During the install I can print a test page, via USB. Can't scan though.

Going to the printer - select Scan button / scan to PC / scan to file / Start times out at "connecting to PC" on the display

In Ubuntu 16.04, running simple scan / select scan times out with the error "failed to scan, unable to connect to scanner"

Retried both of the above after a Ubuntu restart. No joy.

I had a similar problem with brother printer/scanner MFC-J625DW.
Could not get the scanner to work until I followed the instructions on this faq. Second item, "I cannot find the brother machine". Apparently, some files may be copied into the wrong folder. My system is lubuntu 17.10 32-bit and the driver is brscan4.

According to the faq the fix is :
Check if the following directory exist.

For 64bit Users: /usr/lib/x86_64-linux-gnu/sane

For 32bit Users: /usr/lib/i386-linux-gnu/sane

Type the following command if the above directory exists.

For 64bit Users: Command : sudo cp /usr/lib64/sane/libsane-brother* /usr/lib/x86_64-linux-gnu/sane

For 32bit Users: Command : sudo cp /usr/lib/sane/libsane-brother* /usr/lib/i386-linux-gnu/sane

Next to this, your username must also be part of the group owning the scanning device. 'lp' in my case. And if you want to start scanning from the device, you need to install and run first brscan-skey

To clarify I will list all actions I did to get my MFC-J625DW to work (reboot between some steps may be useful):

  • download, unzip and run script for your device from support.brother.com (this installed all necessary packages for my device) Follow all instructions on that site.
  • add myusername to the group lp, owning the scan device sudo adduser <myusername> lp
  • if you need to find out the name of this group, switch on the device, do lsusb, note the busnr and devicenr of the brother, and execute ls -l /dev/bus/usb/busnr/devicenr (3 digits per nr)
  • did the filecopying fix described above
  • to enable all features of brscan-skey, I need gimp, sane and xsane
    sudo apt install gimp
    sudo apt install sane sane-utils libsane-extras xsane

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.