2

I had successfully been using Citrix ICA client 13.3 on Ubuntu 16.04 for quite a while. Recently I bought a new laptop and installed Ubuntu 17.10. I installed the latest 13.7 Citrix .deb, updated the SSL certificates etc and tried to login. However, I got some unfamiliar SSL error (4). After checking some forums I decided to try 13.4. I started off with

sudo apt-get remove icaclient

After that I installed the 13.4 deb. However, I got the same error and noticed there were still stray files left from 13.7, so I tried to completely remove them manually, as below

sudo rm -rf /etc/icaclient/
sudo rm -rf /etc/icalicense/
rm -rf ~/.ICAClient/

I then tried to reinstall 13.4 but it would not even load, complaining of missing .ini files (module.ini, regions.ini etc). I tried touching some and the receiver loaded, but of course complained about invalid keyboard mapping etc. I have come to the conclusion there are still some ICA files on my laptop and I need to delete them before proceeding. Can anyone tell me where they are?

After that, any tips fixing SSL error 4 on Ubuntu 17.10?

Thanks!

1

Try icaclient 13.6.

I had the same error with 13.7 and downgraded to 13.6. I don't have this issue with 13.6 anymore.

  • Thanks but unfortunately the problem is that now no versions of the client will run because (I believe) there are some orphan config files somewhere – P.Windridge Oct 30 '17 at 16:36
  • Ok, the first problem is solved- I should have purged the package not simply removed it. Unfortunately I still get the error with icaclient 13.6 and will try 13.4 – P.Windridge Oct 30 '17 at 16:45
  • 1
    I had to go back to 13.3 and then it worked! :o – P.Windridge Oct 30 '17 at 16:49
1

That is not needed. You can use the latest version just follow my answer here: Certificate error when using Citrix Receiver

Newer versions of the receiver require you to run their util and move the cert as a PEM certificate not the default CRT included with Mozilla ca-certificates.

  • Thanks for the suggestion, I'll give it a try when I next upgrade. However, it should be noted that the SSL error I had was not that I didn't trust the server (as in the linked question). – P.Windridge Nov 10 '17 at 18:38
  • it doesnt matter if you trust it. Citrix Receiver comes with its own certificates that it trusts. You can see that at /opt/Citrix/ICAClient/keystore/cacerts/ if you installed it to /opt as default. So your browsers will still work normally. – Marlon Nov 10 '17 at 22:24
1

Just succesfully installed the citrix client on a fresh ubuntu 17.10, using google chrome.

Download the Citrix Receiver for Linux from: https://www.citrix.com/downloads/citrix-receiver/linux/ Choose the debian packages, webclient only, architecture type depending on your cpu.

Install the package by clicking it (or from the command line if you prefer to type)

Add SSL certificates by executing the following two commands from the command line:

sudo ln -s /usr/share/ca-certificates/mozilla/* /opt/Citrix/ICAClient/keystore/cacerts/

sudo c_rehash /opt/Citrix/ICAClient/keystore/cacerts/

You can now use your webclient.

Resources: https://help.ubuntu.com/community/CitrixICAClientHowTo

  • Ta, that worked for me on Ubuntu 18.04. – dmiller2117 May 10 '19 at 9:49
0

The answer to my first question about removing orphan configuration files is to purge the package rather than simply remove it, e.g.

sudo dpkg -P icaclient

Then I tried 13.6 (didn't work). Then 13.4 (didn't work). Finally 13.3, which I had before (did work).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.