0

First please excuse my english, its not my native language, I am from France.

I decided recently to jump to Ubuntu. So I created a Live USB of Ubuntu, and when I want to install it on my second hard drive which has 3To capacity, the installation program doesn't recognize the free space available on it. It does show them, but doesn't allow me to reduce the free space allocated to Windows to create a new partition for Ubuntu (I'd like to get 100go). Here is a screenshot of the situation : https://img4.hostingpics.net/pics/617661Capturedu20171027224606.png

Sorry the screenshots are in French aswell. I think its still readable, but if you want me to I can make them in English. (/dev/sda is a 250go SSD for Windows)

I tried to create partitions with GParted, the problem is the same. I think it doesn't recognize the file system which is NTFS. I ran disk check in both Windows and Linux, with no errors. I tried by creating a partition from Windows (ext4) successfully, but then Ubuntu doesn't see it at all, showing me the exact same screen.

To clear the situation, here is a Windows picture of my drives : https://img4.hostingpics.net/pics/276947852.jpg I attempt to install Ubuntu on the 195Go unallocated space, but it is unseen.

I ran gdisk -l, maybe you'll see whats the problem on it because I don't. Here are the screens : https://img4.hostingpics.net/pics/793142Capturedu20171028200154.png https://img4.hostingpics.net/pics/546075Capturedu20171028200202.png

Thanks for your help.

  • Ok your freespace is at the end of a large drive (3TB), the problem may be related to drive size limit of the installers file system. – ravery Oct 29 '17 at 12:51
  • try making partitions in windows, then check if the installer sees the partitions. if it does, use manual install option to tell the installer to use them. – ravery Oct 29 '17 at 13:02
  • So here is what I did : img4.hostingpics.net/pics/883345523.jpg (hope it's what you asked, maybe you want me to make more partitions ?) After that I ran Ubuntu and the problem is the exact same. Same description of /dev/sdb, doesn't see the new partition. It seems it just sees the capacity of the drive... not even the file system. By the way, I don't know what is the purpose of the 129MB unallocated space at the start of the drive. But it seems that I can't extend E to it, Windows says it would convert the drive to Dynamic Disk, so I'm just leaving it there. – dunspear Oct 29 '17 at 13:19
  • Any 3GB drive is GPT but you installed Windows (in the 240GB SSD) in Legacy mode which implies MBR (for the SSD) due to Windows strict requirements. Unlike Windows, Ubuntu can be installed in Legacy mode in a GPT drive with a small unformatted "bios_grub" partition if I'm not mistaken. – user692175 Oct 29 '17 at 13:28
  • yes that is what I wanted. I think the issue is drive size. can you easily move the windows partition to the end so the free space is at the beginning? The 125 MB is a windows reserved partition, it needs it. – ravery Oct 29 '17 at 13:33

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.