2

No files or folders are shown on Desktop Ubuntu 17.10.

I have enabled the Show Icons option in Tweak tool.

I also ran:

gsettings set org.gnome.nautilus.desktop volumes-visible true
gsettings set org.gnome.desktop.background show-desktop-icons true

but no success.

1

Gnome Tweaks, installed with Ubuntu Software, should work. I also have the two settings (changed in dconf interface) you list (same values). Additionally, the org.gnome.desktop.draw-background is set to true.

I remember having problems with this in Gnome Classic on 17.04 release. It worked for me eventually, might require session logout. Try using dconf instead of gsettings.

If you have gone through many consecutive upgrades between Ubuntu versions a hard reset might be necessary first. This command will reset all your desktop settings in 17.10 to default so use as a last resort (I had to do this myself for other reasosn): dconf reset -f /

1
  • Probably this could help if I could wait for the answer. I went ahead and freashly installed ubuntu 17.10. I'll try to keep patience next time. – i007 Nov 27 '17 at 6:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.