3

Recently, I got the Ubuntu 17.10 upgrade from this link through command line. I remember getting a ton of y/n questions in terminal so after a while I just stopped reading the options so carefully and answered y to all of them. However, I do remember seeing something to do with efi and I selected yes anyway. The update works fine!

The troubles begin in trying to change BIOS settings. I can get into the BIOS configuration menu by hitting F2 continuously at startup. I can still change all of the options. It even asks me if I want to save my changes, to which I select yes, but at the next reboot, no changes are saved. I can't boot from USB drives either. Furthermore, when trying to go into system setup from the Ubuntu grub menu, it gives me Error: unable to set EFI variable 'OsIndications'

I use an Acer Aspire ES1-511 running a Dual boot of Windows 8 and Ubuntu 17.10. Both operating systems still load perfectly, but as stated above, USB devices can't boot after the upgrade took place.

I suspect that either the EFI partition is mounted as read-only, there are insufficient permissions, or the drive is in the wrong location.

This is the only forum I could find this problem on, but there is currently no solution, so still I cannot change BIOS settings. What went wrong during the update that would make BIOS settings unchangeable? Are there any commands I can try before just waiting for the next Ubuntu release? I'm running a Dual boot, so maybe I can do something from Windows 8? Any help is appreciated!

3
  • There is a small lithium-battery which feeds the hardware clock and the cmos-memory which is used to store BIOS-settings. If the battery is drained, BIOS will fall back to defaults. I assume you should replace the battery with a new one. You may check in your hardware manual how to do this or let a repair service do the job. Related: askubuntu.com/questions/946027/…
    – mook765
    Oct 30, 2017 at 7:34
  • Looks like the EFI variable store is full or damaged somehow. Can you get to a UEFI shell prompt?
    – fpmurphy
    Nov 1, 2017 at 12:45
  • Is this of your interest? phoronix.com/… Dec 21, 2017 at 8:41

3 Answers 3

0

It seems like a specific issue with your laptop. I would try disconnecting disk and going to bios without any disks first. If you still can't change bios settings we can pretty much assume there is not much you can do. You could try upgrading bios to a newer version if you haven't done already though.

My assumption would be that the disk's boot section is confusing the bios and causing it to disfunction somehow. Unplugging the disk will reveal if that's the case.

Also sharing more details about your bios boot section would save you time here. Like sharing whether your usb drives show up in your bios boot menu or not.

I would advise you to try and boot by selection menu, please forgive me for bringing up such a simple detail which everybody already knows about but i had to tell you because you didn't mention it in your post. It's around F5,F6,F7 or ESC keys mostly.

0

I have the same problem and still can't find any way to solve it

but you can try this way on bugs site

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1734147 it worked with some people but failed at me I was removed Ubuntu 17.10 and tried others versions by DVD writer because it caused battery die and when i went to change it by USB removable disk i found the problem,other reason made me remove it before asking about the problem that i found in Disk program 3 snap disks can't to remove theem or formate or any option, so i worried and removed it also if you have login password you will got three options after upgrade and two or the three after fresh copy install, 1- xorg 2- Ubuntu 3- unity if you didn't pressed the icon to choose you will login on xorg There was many problems at me with 17.10 not just the BIOS

0

I solved the problem by upgrading Windows 8 to Windows 10! The BIOS is normal again; live USB drives are able to run, and changed BIOS settings can be saved. Windows has finally made itself useful. Thanks for the help!