2

I recently upgraded from Kubuntu 17.04 -> 17.10 using the upgrade tool. All of my programs/settings/personalization is ok, but many of the drivers are either missing or nonfunctional. This includes sound (Both Integrated Speakers, USB Speakers, and Bluetooth Speakers) Additionally my USB Bluetooth adapter may be malfunctioning due to the driver(Mpow Jaws Bluetooth Headset Auto Rejection Upon 17.10 Upgrade).

This also includes my USB Wi-Fi adapter as well. The internal Wi-Fi card may still be disabled because I had to to enable the external USB one (Which has a higher range than my internal antenna. Basically all the steps we did to enable the USB antenna (Wireless antenna does not appear despite its driver being installed)

I should note that graphics drivers appear to be fine (At least from the System Settings Dash anyway.... I'm using an Nvidia graphics driver and all appears to be well on that frontier)

I'm still new to the upgrade, if I find anything else that broke, I'll post it.

Edit 0: I should note that the Wired connection that I'm using is ok, and that I can connect to the network from there, and that's how I'm making posts. Seeing a similar question to the Wi-Fi issue I went to (No internet after upgrade to 17.10) and they linked me to (https://askubuntu.com/a/907249/645874) I attempted the fix and got a green status.Green Status The issue persists, although, granted I haven't had time to restart the system yet.

Edit 1: I executed most of the lines from your solution, but hit a snag on the dkms region

sarah@ConvergentRefuge:~$ sudo dkms uninstall rtl8812au/5.2.9 Error! Could not locate dkms.conf file. File: does not exist. sarah@ConvergentRefuge:~$ sudo rm /usr/src/rtl8812au-5.2.9 rm: cannot remove '/usr/src/rtl8812au-5.2.9': No such file or directory sarah@ConvergentRefuge:~$ sudo rm -rf /usr/src/rtl8812au-5.2.9 sarah@ConvergentRefuge:~$ sudo rm -rf ~/rtl8812au-driver-5.2.9 sarah@ConvergentRefuge:~$ rm -rf rtl8812au sarah@ConvergentRefuge:~$ git clone https://github.com/gnab/rtl8812au.git Cloning into 'rtl8812au'... remote: Counting objects: 607, done. remote: Total 607 (delta 0), reused 0 (delta 0), pack-reused 607 Receiving objects: 100% (607/607), 1.67 MiB | 10.32 MiB/s, done. Resolving deltas: 100% (250/250), done. sarah@ConvergentRefuge:~$ sudo cp rtl8812au /usr/src cp: -r not specified; omitting directory 'rtl8812au' sarah@ConvergentRefuge:~$ sudo cp -r rtl8812au /usr/src sarah@ConvergentRefuge:~$ sudo dkms add -m 8812au -v 4.2.2 Error! Could not find module source directory. Directory: /usr/src/8812au-4.2.2 does not exist.

I also tried a variation of it:

sarah@ConvergentRefuge:~$ sudo dkms add -m rtl8812au -v 4.2.2 Error! Could not find module source directory. Directory: /usr/src/rtl8812au-4.2.2 does not exist. sarah@ConvergentRefuge:~$

  • reboot. Many of those issues may be kernel related, you can also try an older kernel. – Panther Oct 28 '17 at 15:35
  • @Panther System was rebooted, issue still persists. Do you think that I should go to the last kernel that I used? – Sarah Szabo Oct 28 '17 at 17:47
  • yes, please try an older kernel, one known good. – Panther Oct 28 '17 at 17:48
  • Are you trying to fix resolv or are you trying to install the wireless driver? If resolv is working in ethernet, i.e. you can reach the internet with ethernet, then resolv is working properly. Please clarify. – chili555 Oct 28 '17 at 18:14
  • @chili555 The problem in the DNS fix wasn't the type of problem I was having. It was just the fix that another person recommended for Wi-Fi issues after upgrading. I'm looking to restore Wi-Fi capability and sound. I'll try the previous kernel. – Sarah Szabo Oct 28 '17 at 18:21
3

With a working internet connection, open a terminal and enter these commands one at a time:

sudo apt update && sudo apt install git

If it is already installed, please just continue.

First, let's clean away the steps that we've shown are not working:

sudo dkms uninstall rtl8812au/5.2.9
sudo rm /usr/src/rtl8812au-5.2.9
sudo rm ~/rtl8812au-driver-5.2.9
rm -rf rtl8812au

Next, please do:

git clone https://github.com/gnab/rtl8812au.git
sudo cp -r rtl8812au  /usr/src/rtl8812au-4.2.2
sudo dkms add -m rtl8812au -v 4.2.2
sudo dkms build -m rtl8812au -v 4.2.2
sudo dkms install -m rtl8812au -v 4.2.2

Reboot and tell us if the wireless is working.

  • This was done in the 4.10 kernel, but it still doesn't work. I can reattempt in the newer kernel if you want. – Sarah Szabo Oct 28 '17 at 19:06
  • Please do and note my edit above in a few moments. I don't think you used the zebulon2 git repository previously, however. – chili555 Oct 28 '17 at 19:10
  • I'm guessing that I did, because I got an error message suggesting that I did after executing the first line fatal: destination path 'rtl8812au-driver-5.2.9' already exists and is not an empty directory. – Sarah Szabo Oct 28 '17 at 20:12
  • No effect on either kernel. – Sarah Szabo Oct 28 '17 at 20:28
  • Yes, I repeated all steps in your post after edit. This included the Zebulon 2 directory. – Sarah Szabo Oct 28 '17 at 21:04

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.