4

I've dug through old questions, and the only ones I found that seemed to address this were five or six years old, referencing folders that don't exist in my install. I'm on 16.04 Mate, trying to get Deja-Dup to let me start completely over as if never run before, but I'd be happy if I could just get to the point of verifiably complete backups that actually ignore the folders I've specified to be ignored.

As it stands, every time Deja-Dup runs a backup (whether manual or automatic), it stops with a message that

can't back up file /home/[user]/.cache/dconf

I presume this is happening because the file is open, but I would expect backup software to be able to work around that.

  • I've verified multiple times that ~/.cache is in the "ignore" list (in fact, it appears twice, even though I've deleted it completely from the list and reentered it a single time).
  • I've also tried individually adding folders inside ~/.cache; they show in the list, but I included ~/.cache/dconf and still got the same error.

At this point, I've got a Google Drive folder full of duplicity files and can't tell which is what, can't tell whether Deja-Dup is backing up everything except the file that generates the error, or only files handled before the error, don't see why I'm getting duplicates of folders shown in the "ignore" list -- and I think it would be simpler to remove Deja-Dup entirely and start over.

I found an answer that suggests purging the deja-dup package, but when I simulate purging Deja-Dup, I get this:

Reading package lists... Done Building dependency tree Reading state information... Done The following packages were automatically installed and are no longer required: libntlm0 linux-headers-4.10.0-28 linux-headers-4.10.0-28-generic
linux-headers-4.10.0-33 linux-headers-4.10.0-33-generic
linux-image-4.10.0-28-generic linux-image-4.10.0-33-generic
linux-image-extra-4.10.0-28-generic linux-image-extra-4.10.0-33-generic Use 'sudo apt autoremove' to remove them. The following packages will be REMOVED: deja-dup* deja-dup-backend-cloudfiles* deja-dup-backend-gvfs*
deja-dup-backend-s3* deja-dup-caja* ubuntu-mate-desktop* 0 upgraded, 0 newly installed, 6 to remove and 0 not upgraded. Purg ubuntu-mate-desktop [1.154.1] Purg deja-dup-backend-s3 [34.2-0ubuntu1.1] Purg deja-dup [34.2-0ubuntu1.1] [deja-dup-backend-cloudfiles:amd64 deja-dup-caja:amd64 deja-dup-backend-gvfs:amd64 ] Purg deja-dup-backend-cloudfiles [34.2-0ubuntu1.1] [deja-dup-caja:amd64 deja-dup-backend-gvfs:amd64 ] Purg deja-dup-backend-gvfs [34.2-0ubuntu1.1] [deja-dup-caja:amd64 ] Purg deja-dup-caja [0.0.4-0ubuntu2]'

I presume this would only be uninstalling the mate-desktop meta-package, since it doesn't list hundreds of dependencies that would amount to removing my DTE -- but the other questions I've seen suggest this alone won't fix the problem, and Ubuntu has changed enough since 10.04 or 11.04 that some of the referenced folders don't exist or aren't where prior answers assume they are.

Since someone apparently thought it was unclear what I'm asking: given the information above, how do I either completely purge Deja-Dup without removing my desktop, so I can reinstall it clean -- or how can I make Deja-Dup work like new, correctly ignore the folders it shouldn't back up, and make backups I can depend on?

Followup: After implementing the "just purge the settings" part of the solution below, Deja-Dup ran a full cycle but failed with a completely different error that seems to have come up at the very end of the "first backup" cycle -- after writing 300 MB of backup files and a signatures file, writing the manifest file failed with an error dump. I'm going to start over, and if I reproduce the error, I'll search or ask a different question on how to resolve that.

  • In that case just remove and don't purge it! – George Udosen Nov 15 '17 at 5:27
  • Look at what gets remove with sudo apt-get -s remove deja-dup and see if it keeps your desktop, I believe it does! – George Udosen Nov 15 '17 at 5:34
  • @George read the question again. Only difference between purge and remove is the former also removes config files. Packages removed are the same either way. The -s I ran says it's removing ubuntu-mate-desktop. Looks a lot like leaving me at a command line with a lot of tools missing. – Zeiss Ikon Nov 15 '17 at 12:08
  • I get this error too. Are you by any chance running 14.04 or 16.04 ? (I am) This bug report bugs.launchpad.net/deja-dup/+bug/1313034 says that the problem is fixed in duplicity v. 0.708...., 14.04 has version 0.6 and 16.04 has 7.06.... However, this error does not seem to affect functionality. – Organic Marble Nov 17 '17 at 19:55
2
+100

As you correctly assumed ubuntu-mate-desktop is only a meta-package (try apt show ubuntu-mate-desktop for confirmation. So as long as you don't issue sudo apt autoremove nothing bad will happen, even if you purge the deja-dup package.

The next step is to remove the configuration (stored in dconf)

  1. back up the complete dconf-database:

    tar cf config-dconf-user .config/dconf/user
    

    (you can restore it with tar xf config-dconf-user)

  2. purge the deja-dup settings

    dconf reset -f /org/gnome/deja-dup/
    

Now you can reinstall deja-dup.

N.B.
You probably could try and purge only the deja-dup settings, without removing/purging the package

  • This looks promising. I'll try it when I get home. – Zeiss Ikon Nov 17 '17 at 19:49
  • As suggested, I was able to purge the deja-dup settings and once that was done, there was no need to purge and reinstall the application. I could then start with an unconfigured deja-dup and set up my ignore folders and backup folders from scratch -- also moving all the old backup files into a storage folder so they wouldn't interfere with the process. Backup running now, but this has fixed the issue with duplicating ignore folders and such -- deja-dup acts as if freshly installed, so I'm going to award the bounty and accept the answer. – Zeiss Ikon Nov 17 '17 at 23:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.