6

By default Ubuntu Dock in Ubuntu 17.10 and later releases always extends to the edges (top-bar-to-bottom if placed on the left or right and left-to-right when placed at the bottom) even when it's not filled with icons.

Is there a way to prevent this behaviour (i.e. I want to make the dock-length flexible, as the number of application icons in the dock increases it should expand accordingly)?

In other words, is there a way make Ubuntu Dock look like a "proper dock" instead of a side/bottom panel?

13

Open Terminal and run

gsettings set org.gnome.shell.extensions.dash-to-dock extend-height false

To revert to the "panel mode" run

gsettings set org.gnome.shell.extensions.dash-to-dock extend-height true
  • 1
    Also, if you want a graphical tool, install dconf-editor, and navigate to the path @pomsky provided (/org/gnome/shell/extensions/dash-to-dock). – PJ Singh Oct 28 '17 at 23:45
2

Using either the Gnome Tweak Tool, or https://extensions.gnome.org/local/, disable the 17.10 built-in Ubuntu Dock extension, and install the more configurable Dash to Dock extension, and it'll give you the shorter dock you desire.

https://extensions.gnome.org/extension/307/dash-to-dock/

  • 1
    I tried disabling Ubuntu Dock using Tweaks and extensions.gnome.org/local in a live USB session and restarted GNOME shell (Xorg session). It seems they're not working, dock stays active. – pomsky Oct 30 '17 at 10:01
  • 1
    @pomsky I don't know if working in a live USB session makes it reload a gnome session default when restarting gnome, or why that wouldn't work. In a real session, disabling the built-in Ubuntu Dock and enabling the Dash to Dock extension from extensions.gnome.org works fine, just the way it's supposed to. – heynnema Oct 30 '17 at 13:08

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.