2

Is it possible to have sound muted by default in ubuntu 17.10?

I have a cherry trail laptop with intel x5-z8350 processor. More info about my laptop, as you can see there are audio devices listed and recognized:

aplay -l
**** Lista PLAYBACK urządzeń ****
karta 0: Audio [Intel HDMI/DP LPE Audio], urządzenie 0: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
  Urządzenia podrzędne: 1/1
  Urządzenie podrzędne #0: subdevice #0
karta 0: Audio [Intel HDMI/DP LPE Audio], urządzenie 1: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
  Urządzenia podrzędne: 1/1
  Urządzenie podrzędne #0: subdevice #0
karta 0: Audio [Intel HDMI/DP LPE Audio], urządzenie 2: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
  Urządzenia podrzędne: 1/1
  Urządzenie podrzędne #0: subdevice #0
karta 1: bytcrrt5651 [bytcr-rt5651], urządzenie 0: 1 []
  Urządzenia podrzędne: 1/1
  Urządzenie podrzędne #0: subdevice #0
karta 1: bytcrrt5651 [bytcr-rt5651], urządzenie 1: Deep-Buffer Audio (*) []
  Urządzenia podrzędne: 1/1
  Urządzenie podrzędne #0: subdevice #0
kamila@Kiano:~$ 

 inxi -F
System:    Host: Kiano Kernel: 4.13.0-16-generic x86_64 bits: 64
           Desktop: Gnome 3.26.1 Distro: Ubuntu 17.10
Machine:   Device: laptop System: KIANO product: KIANO SlimNote 14.1 serial: N/A
           Mobo: AMI model: Cherry Trail CR serial: N/A
           UEFI: N/A v: WH-BI-14-Y116CR510-CC54B-063-A date: 08/16/2017
CPU:       Quad core Intel Atom x5-Z8350 (-MCP-) cache: 1024 KB
           clock speeds: max: 1920 MHz 1: 1440 MHz 2: 1440 MHz 3: 1440 MHz
           4: 1440 MHz
Graphics:  Card: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers
           Display Server: wayland (X.Org 1.19.5 ) driver: i915
           Resolution: 1366x768@59.80hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics (Cherrytrail)
           version: 4.5 Mesa 17.2.2
Audio:     Card-1 Intel HDMI/DP LPE Audio driver: HdmiLpeAudio
           Card-2 bytcr-rt5651 driver: bytcr-rt5651
           Sound: Advanced Linux Sound Architecture v: k4.13.0-16-generic
Network:   Card: Failed to Detect Network Card!
Drives:    HDD Total Size: NA (-)
           ID-1: /dev/mmcblk0 model: N/A size: 31.3GB
Partition: ID-1: / size: 29G used: 9.1G (34%) fs: ext4 dev: /dev/mmcblk0p2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 42.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 209 Uptime: 10 min Memory: 809.1/3872.9MB
           Client: Shell (bash) inxi: 2.3.37 

Thanks!

1

The above solution Will solve the problem sound but only headphones work.. Use the kernel 4.19 It supports the device well speakers will work Disable/ enable the sound card whenever you change the port Use alsamixer to look for left and right controls (HPO L...)

| improve this answer | |
0

i have a very similar setup with bytcr-rt5651 and ubuntu 17.10 this fixed mine:

  1. in etc/modprobe.d create file blacklist_hdmi.conf with contents:

blacklist snd_hdmi_lpe_audio

  1. download and run this linixium sh script:

https://drive.google.com/file/d/0B99O3A0dDe67VUNMV2xfVjJKeVk/edit

  1. in /usr/share/alsa/ucm/ create a bytcr-rt5651 folder with contents:

asound.state

bytcr-rt5651.conf

HiFi.conf

  1. sudo alsa force-reload
  2. rm -r ~/.pulse ~/.asound* ~/.pulse-cookie ~/.config/pulse
  3. pulseaudio -k
  4. reboot
  5. open pavucontrol and set configuration profile to HiFi and change output from headphones to speakers.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.