4

I have TeamViewer 12 installed on my a few computers around the office. On a Windows 10 machine, 2 Linux Mint ones, my mobile and Ubuntu 17.10. And I can access everything from everything except Ubuntu 17.10.

Every time I try to remote access Ubuntu's desktop all I get is:

  • ERROR
    • No connection to partner.
    • Partner did not connect to router.
    • Error code: Wait for network failed.

That, even though the Ubuntu PC is online and the TeamViewer client on it perfectly functional. I can have a meeting or a chat using teamviewer but it simply refuses to let me remote control the Ubuntu pc.

So to get this right, after Ubuntu devs broke the default state of several popular programs including Steam Client now they're breaking team viewer too? Just stop pushing users away from your own product.

But back to the topic: Any idea about how I could get this fixed? I tried a few things including restarting daemon but nothing worked. Any advice aside replacing Ubuntu with Mint that I already have in mind would be most appreciated. Thank you!

  • 1
    Not completely sure, but I think if you're in a Wayland session, switching back to an Xorg session might fix many of the issues. – pomsky Oct 28 '17 at 11:54
  • And you're absolutely right my friend. Switching bk to Xorg worked perfectly! Thank you very much! – John E.K. Oct 28 '17 at 12:34
7

At present Teamviewer does not support Wayland:

At the moment, our developers are working on a Linux Native version for Linux but there's no release date or information about features included. I will forward your suggestion to support Wayland our product management team.

Until this was resolved we should switch back to Xorg:

|improve this answer|||||
-1

If you have SSH to connect to the Ubuntu system remotely try in the console:

sudo teamviewer daemon restart

You may set passwords 4 remote connection with:

sudo teamviewer --passwd [yourpassword]
sudo teamviewer --info - show you teamviewer ID
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.