1

On my external HD, I have a directory in my trash (media/me/Seagate Backup Plus Drive/.Trash-1000/files) that appears very difficult to delete. Considering my troubleshooting notes below, what else can I try to get it off my HD?

  • When I click 'empty trash' from the file browser, any file browser windows related to the drive appear to hang.
  • When I try to use rmdir to delete the directory, it reports that there is no such file or directory.
  • When I try to use sudo to delete the .Trash-1000 directory, sudo hangs.
  • I installed trash-cli and tried that, too. It also reported that there is No such file or directory.
  • I also installed secure-delete and found sudo srm -rf .Trash-1000 from within /media/me/Seagate Backup Plus Drive to hang.
  • Until I try to empty my trash, I seem to be able to use the external HD as normal (it reads and writes).
  • The HD is formatted as NTFS.
  • Starting at the root of the HD, all files and folders along the path to the problem directory are owned by me (user and group), and have all permissions flags set (drwxrwxrwx).
  • I have used 'safely remove drive' to unmount and re-mount the drive several times, and it doesn't seem to have made any visible difference to the above.
3
  • Please open a terminal (Ctrl+Alt+T) and then run the command mount -l | grep media while the external drive is connected and add the terminal-output to your question. This way we can see if your drive is mounted correctly or not. – mook765 Oct 28 '17 at 13:47
  • Thanks for the suggestion. Unfortunately I did find the solution before noticing your comment, sorry for the late reply. If it interests you, a post-mortem mount -l | grep media lists the external HD normally. – Andre Nov 11 '17 at 4:19
  • . Trash-1000 is created by default by any Linux system. You should not worry about it. – digiwizkid Nov 11 '17 at 4:58
0

I ended up using Windows to solve this.

To do so, I plugged in the External HD and browsed into the .Trash-1000 folder with the file explorer. The file explorer paused, thinking, for a couple of seconds, and then eventually presented the contents of the folder as empty. I then simply unmounted the HD, rebooted into Linux, and it seems to me that everything has worked as expected since.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.