1

I am trying to install Torch using this thread

And when I tried run ./install.sh which installs LuaJIT, LuaRocks, and then uses LuaRocks (the Lua package manager) to install core packages like a torch, an NN and paths, as well as a few other packages.

I am getting this error:

CMake Error at /usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:148 (message): Could NOT find CUDA (missing: CUDA_INCLUDE_DIRS CUDA_CUDART_LIBRARY) (found suitable version "8.0", minimum required is "6.5") Call Stack (most recent call first): /usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:388 (_FPHSA_FAILURE_MESSAGE) /home/htic/torch/install/share/cmake/torch/FindCUDA.cmake:1009 (find_package_handle_standard_args) CMakeLists.txt:7 (FIND_PACKAGE)  
-- Configuring incomplete, errors occurred! See also "/home/htic/torch/extra/cutorch/build/CMakeFiles/CMakeOutput.log".  
Error: Build error: Failed building.

In bash file, I have tried:

export LD_LIBRARY_PATH="/usr/local/cuda-8.0/lib64/:$LD_LIBRARY_PATH"
export CUDNN_PATH="/usr/local/cuda-8.0/lib64/libcudnn.so.6" export CUDA_INCLUDE_DIRS="/usr/local/cuda-8.0/include"

and creating a symlink /usr/local/cuda-8.0 as /usr/local/cuda but still, the error persists.

1 Answer 1

-1

I had the same issue. A combination of the following things helped:

  • installed CUDA 9.1 with deb package and ran

    sudo apt-get remove nvidia-cuda-toolkit
    

    which I had installed previously and which gave me CUDA 7.5

  • ran

    sudo apt-get autoremove
    
  • before trying again to run ./install.sh I ran "sudo ./clean.sh" in the torch directory

(I am using Linux Mint 18)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .