1

I’m using Ubuntu 17.04 on my laptop. I’m not sure how the issue started since it is by no means a fresh install. I’m unable to resolve any DNS hostnames via browser or telnet. I’ve confirmed this on the laptop in question over multiple WiFi networks. I also confirmed that other devices on the same network are not experiencing this issue. I can ping any external IP address (e.g. 8.8.8.8) just fine. I can also visit websites by typing the IP address into the browser.

Things I have tried:

  • I tried running sudo dpkg-reconfigure resolvconf to no effect.

  • I’ve also tried going into the network settings for the WiFi network and changing the Method to “Automatic (DHCP) addresses only”, then manually adding DNS server addresses.

  • I also tried adding a supersede domain-name-servers line in my etc/dhcp/dhclient.conf file which did not resolve the issue either.

  • I even manually edited my /etc/resolv.conf to replace my nameserver with 8.8.8.8.

  • Adding dns-nameservers to /etc/network/interfaces file has not helped either.

After each of these experiments failed to enable DNS lookups I restored the original config. I’m not able to install external packages right now such as dnsmasq. Can anyone point me in the right direction? I really am not sure how I got in this mess, but it’s persistent after rebooting as well. I’m not behind a VPN.

0

I resolved this by reinstalling my entire operating system. I switched to the LTS line in case the issue was partially caused by some system update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.