0

On 17.04 everything worked fine. I can switch between gfx cards with prime-select. It requires logout-login routine but works. In 17.10 I have issue with that. Switching from Intel to Nvidia works ok. After switch, I have to run command:

sudo systemctl restart display-manager

When I try back to Intel I can switch it with prime-select, I can restart display-manager and use Intel gfx but Nvidia modules are still used. I tried to to find what using Nvidia modules but without success.

$ lsmod | grep nvidia nvidia_drm 45056 3 nvidia_modeset 843776 1 nvidia_drm nvidia 13004800 1 nvidia_modeset drm_kms_helper 167936 2 i915,nvidia_drm drm 356352 26 i915,nvidia_drm,drm_kms_helper

I don't know what is using nvidia_drm module.

Update: I checked how optirun behaves and it is same situation. After quit from program that was run as parameter of optirun command, Nvidia modules cant be unloaded.

Update 2: Problem from Update 1 I resolved by fixing path to nvidia-persistentd in systemd service file. Now nvidia-persistentd service starts properly. But this is not solution for main problem.

Update 3 Dirty solution is to use magic sysrq combination with E

RAlt+SysRq+e

After this, I can unload Nvidia driver but it breaks some system services. Still searching perfect solution...

Update 4 I found that dbus service is blocking nvidia_drm module. After killing it I can remove nvidia modules from memory but Gnome not working fully. Even after restart of dbus service.

4
  • What happens when you switch & reboot? – doug Oct 27 '17 at 22:47
  • You mean switch to Intel and reboot? It behaves as expected. Intel gfx is used and Nvidia modules isn't. – QkiZ Oct 28 '17 at 6:33
  • In 17.10 (with gdm3) when switching via nvidia-prime a reboot is always needed unlike previous Ubuntu releases (lightdm) where a log out/in was good enough – doug Oct 28 '17 at 12:05
  • But in one way it works fine (Intel->Nvidia). No reboot needed. I think that some service is still using this module. I will try trial and error method to find this service. – QkiZ Oct 28 '17 at 12:13
0

I am having similar issues, where my Nvidia card is keeping my Arch/Ubuntu (tried both) from giving me a video signal after reactivating from suspend. SSH etc works. This did it for me

  sudo rmmod nvidia-drm
  sudo rmmod nvidia-modeset
  sudo rmmod nvidia_uvm
  sudo rmmod nvidia
  sudo systemctl start lightdm

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.