A red triangle with an exclamation mark prompted me to search for the reason my system was not able to install updates. I found a site that said to run:

sudo apt-get update
sudo apt-get upgrade

This fixed my issue and the triangle was gone. Then a message popped up and said Ubuntu had a problem. I restarted and Ubuntu hung up on the Ubuntu splash screen. I had made no changes and system had been running fine until today.

It looks like he system may be booting because I am able to access a Confluence server site that I installed. I just cannot get past the Ubuntu splash screens.

I am able to start up from a USB if that helps.

Thanks in advance for any help.

I wanted to add further troubleshooting on my part. I have been able to boot into my original logon screen and desktop. I did this by:

  1. While booting - hold down shift key to see GRUB menu
  2. Selected recovery mode
  3. Select dpkg from recovery menu
  4. fix broken packages
  5. restart system

Now I am back to what started this problem. During logon, I see an window that says Ubuntu has experienced an internal error. It also says 'If you notice further problems, try restarting the computer.' I did restart yesterday and that is when my problem started. How do I fix the internal error and not be afraid to restart?

Looks like I have obsolete package versions that I need to upgrade based on the 2nd screen capture.

InternalError

enter image description here

  • Additional info - I have been able to get into grub by holding down the shift key at boot. I selected Advanced options and then selected what I think is an old kernel - 4.10.0-35 -generic. I get a logon screen and after I enter my password, I see a dialog window come up that says a system problem has been detected - it goes away and then I loop back to the logon screen. – lonslo Oct 28 '17 at 1:15
  • More Info - looks like a video problem. I 'bypassed' my NVIDIA GeForce GT 730 by using onboard HDMI. It allows me to boot into low graphics and says graphics could not be detected and I must configure these myself. Maybe the update/upgrade command(s) I ran wiped out my nvidia drivers because it was working fine before I ran those commands. My system is a Dell XPS 8900, i7-3.4GHz, 16GB RAM and the NVIDIA GT 730. – lonslo Oct 28 '17 at 2:00
up vote 0 down vote accepted

I have found my solution. I ran sudo apt-get update. To 'apply' the updates, I went to Ubuntu Software and applied the OS updates from there. Once the update had completed, I restarted. There were no problems. I restated one more time to check for stability and it was fine - no errors.

  • You should be able to do both update and upgrade, either in terminal or in Ubuntu Software. In terminal run sudo apt update to update repositori databases and sudo apt upgrade to upgrade packets. OR in Ununtu Software, choose Updates-tab, click on the update icon (round arrow) and when it has finished, click on Update. Personally, I prefer the terminal way, since it is easier to see what goes on. – Soren A Oct 30 '17 at 12:21

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.