it seems that mysql has been upgraded today to ver. 5.7.20-0ubuntu0.16.04.1

I can't start the mysql server since because of InnoDB: When I set

innodb_data_file_path = ibdata1:2M:autoextend

(which I found out should be the correct size) I get the error

[ERROR] InnoDB: Tablespace size must be at least 5 MB

When I set it to

innodb_data_file_path = ibdata1:5M:autoextend

I get the error

InnoDB: The Auto-extending innodb_system data file './ibdata1' is of a different size 128 pages (rounded down to MB) than specified in the .cnf file: initial 320 pages, max 0 (relevant if non-zero) pages!

Do I miss something? How do I get it fixed?


1 Answer 1


I got it working now with help from this thread: MySQL not working after upgrade from 14.04 to 16.04

I had to remove these two lines from my.cnf

key_buffer_size = 16M
myisam-recover-options  = BACKUP

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .