0

i am using Ubuntu 16.04 lts on a Thinkpad t440s. The build in Cardreader always worked well till a point when it did not recognize cards and i had to reenter them several times. One SD card broke. But then it worked well for a long time. Now a different Problem occurs.

1) When i try to copy a whole lot of files on the SD Card (128GB/exfat) i takes a lot of time and the transferrate is XX kbytes/s. If the amount is to high or i copy very large files it interrupts the procedure with I/O ERROR.

2) When i try the exact same SD Card in an external USB Reader everything works fine! The transferrate is about 20mb/s and i get no errors. So the SD Card is fine, i also checked badblocks and fsck: No Errors.

3) When i try another SD Card (32gb/fat32) works fine.

 output of mount, (not working 128 gb):   
/dev/mmcblk0p1 on /media/crubuntu/SDXC type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)

output of mount (working, 32gb):
/dev/mmcblk0p1 on /media/crubuntu/3134-6333 type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,flush,errors=remount-ro,uhelper=udisks2)

The Card reader: 14cd:6700 Super Top Card Reader

Everything seems like there is an Software error or something. I already tried: Reinstall usidsk2, Card Formatted as fat32, formatted as ntfs.

if any addition Information is needed, i will provide.

I would be glad to hear from you guys.

thanks!

4
  • For exFAT you need to install support for exFAT but if it works in an external reader you already have it so it follows the internal reader is most likely not compatible with 64GB+ cards.
    – user692175
    Oct 27, 2017 at 16:13
  • Back in the days on Windows it worked well with this card. Maybe the driver does not get along
    – Crubuntu
    Oct 27, 2017 at 16:17
  • Have you installed support for exFAT? > askubuntu.com/a/451376/692175 That is if you want to keep the file system. Formatting as NTFS will have the same advantage and mature support.
    – user692175
    Oct 27, 2017 at 20:13
  • Yes ofc both are installed. I can mount and read the card without problems
    – Crubuntu
    Oct 28, 2017 at 8:02

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy