18

I upgraded my PC to Ubuntu 17.10, and now that I've restarted my PC I get this message:

Failed to connect to lvmetad.
Falling back to device scanning.
/dev/mapper/ubuntu--vg--root: clean, 500699/15081472 files, 9150222/60315648 blocks

It gets stuck on this.

What's the problem and how can I fix it?

2
  • 2
    Until someone can weigh in on a real solution, I've found booting with an older Kernel works. At boot time, pull up your boot menu (for me, hitting "Esc" or "F9" at the BIOS screen), then select "Ubuntu with Advanced Options" then pick an older Kernel version #. – chucksense Oct 27 '17 at 19:37
  • I ran into this on Ubuntu 18.04 with 4.15.0-74, 4.15.0-72 worked – sdaffa23fdsf Jan 14 '20 at 5:15
8

I had a very similar experience, not sure if it'll help you though. My computer had some updates installed, needed a reboot but hey, nobody got time for that. Well along came a power outage and forced me to reboot. When I turned on my machine, I got just the same message you saw. Crap. I couldn't even get into virtual terminals 1 or 2 either which was really weird. Anyway, I somehow found your post and read that switching the kernel version made everything work. So I went and tried that out and sure enough, what you said applied to me too.

With my primitive knowledge of linux commands, I did get an idea of how to fix this. So I rebooted into the newest kernel, then switched to the virtual terminal ctrl+alt+f3 <- had to use the third because 1 and 2 weren't working. From here I ran sudo apt-get update && sudo apt-get upgrade -y to get everything up to date. Then ran sudo apt-get autoremove to remove the older kernels. Then I re-installed the current kernel (get the version from uname -r) and then I ran sudo apt-get install --reinstall linux-image-4.13.0-32-generic to reinstall the current kernel and rerun all the building of things that might not have been run since I didn't switch to this kernel properly. Finally, I restarted again.

After the restart I was having the same problem still. Welp, maybe it has to do with my graphics drivers? So I went ahead and purged my nvidia drivers sudo apt-get purge nvidia-* and reinstalled the drivers sudo apt-get install nvidia-387 ~ Granted, I don't know what version of their driver I should be using, nvidia afik doesn't have just a standard package that you can install that follows the latest - but this one installed just fine for me... After that super slow install, I restarted again.

And my computer came back to life. Woohoo. I genuinely hope this helps someone. It took me 4 hours of frustrated pounding to get my desktop back and I really hope I can save someone else from that. Thanks for your post and your update, you gave me the lead that I needed to solve this for myself.

3
  • 1
    It really seems that nvidia drivers are causing this issue. After purging nvidia I could get on my desktop and use the generic display driver that linux provides. – Ravers Feb 6 '18 at 11:47
  • Yes, this is the right answer. Actually I guess lvmetad is never working, but the driver error brings us to the blackscreen and make it apparent. At last I saw some hdaudio error. I got this error after apt upgrade, and after checking dpkg logs, I found that all drivers are HWE versions, not normal GA versions. So I installed all Intel video drivers and xserver libinput drivers back(HWE versions), and system is back online. Thanks a lot. – WesternGun Mar 29 at 9:13
  • @WesternGun I agree with the assessment about lvmetad being a red herring, I occasionally notice the error during boot but the system starts up just fine. But as I recall it was the only error I was able to see. And I'm glad that this rambling answer was helpful for you! – Blakethepatton Mar 31 at 18:37
2

The accepted answer helped me quite a lot (thank you!)

Though in my case neither booting with an older kernel nor the nvidia driver could solve it... it just turned out my disk had run full (as I saw with df). I could delete files by booting into recovery mode and from then on boot normally again :)

I hope this hint is useful to anyone stuck in this situation

1

In my case I saw this error after apt upgrade, and when I use recovery mode to reinstall the kernel(get version by uname -r), I finally see some error of hdaudio.

Then, I check dpkg logs by

cat /var/log/dpkg.log | grep "xorg-xserver-video*"

and found that the earliest, working version of drivers are HWE versions(have "-hwe" in name), but now dpkg -l | grep xorg-xserver-video shows that it is not installed(not in ii state, maybe removed by apt upgrade).

So I enable the network in recovery mode, installed them back(actually only xorg-xserver-video-all-hwe-18.04), along with xorg-xserver-input-all-hwe-18.04(drivers for input, as during the first successful boot I cannot use mouse nor keyboard), and reboot. Good again.

Thanks! I will never upgrade Intel or Nvidia drivers again. I guess that lvmetad never worked from the beginning, but it does not prevent the OS from boot so we never saw it, until the failure of video driver brings us to the black screen, thus the wrong impression.

1
  • Also, remember to remove any package of video driver you installed recently, for example, displaylink-driver – WesternGun Apr 5 at 15:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.