27

I updated my Ubuntu version to 17.10 and I want to configure switching to next input source via CapsLock button. I tried to set CaspLock in keyboard setting, but I cant because nothing happening.

I did actions explained here How to switch input language on Caps Lock in Ubuntu 15.10 Gnome 3.16 and it works, but now when I switching input source I see a pop-up (like as pop-up that shows switching application windows) and must wait a few seconds until it disappears.

How I can resolve my problem?

1

2 Answers 2

43

By trial and (a lot of) error, this works for me (I'm not sure whether the first three steps are required).

  1. Open Settings (the default system setting app).
  2. Go to Devices -> Keyboard and press Reset All....
  3. Close the Settings app.
  4. Install gnome-tweak-tool and open it.
  5. Go to Keyboard & Mouse -> Additional Layout Options
  6. Seek for Switching to another layout and unchecked every options under that setting.
  7. Restart the Tweaks app.
  8. Repeat step 5-6 again, only this time make sure you check the one and only Caps Lock option.
  9. Close the Tweaks app, now you should use the caps lock button to switch language without popup menu to delay the input :D
5
  • 2
    What option I must check in tweak app? I checked CapsLock option "Capslock is disabled", after I used Casplock button to switch language and button what determined like "0xff" and It doesnt work.
    – lupti_du
    Oct 29, 2017 at 11:10
  • 2
    Hmm, during my process I didn't encounter "Capslock is disabled" at all. Sorry I don't know how to help you.
    – neizod
    Oct 29, 2017 at 18:23
  • 2
    Im sorry, I read inattentively, It works, big thanks.
    – lupti_du
    Oct 30, 2017 at 8:05
  • 1
    "Go to Keyboard & Mouse -> Additional Layout Options" there it is! THANK YOU! When upgrading to 20.04 I chose Caps lock to switch input sources. However, this actually just caused capslock to get stuck, meaning I was screaming the whole time, both literally and well... literally :-D
    – andsens
    Oct 6, 2020 at 7:25
  • 1
    Works on Ubuntu 22.04.3 as well. Thanks you! gnome-tweak-tool can be install using sudo apt install gnome-tweaks Aug 17, 2023 at 19:21
2

If you don't like the popup, install the Quick Lang Switch Gnome-shell extension to avoid the delay of the switcher popup - now switching languages happens instantaneously. Plus, it does not define a custom-shortcut, so all customizations with gnome-tweak-tool/setxkbmap in X11 or Wayland still work fine.

NOTE: this is not a solution for using [CapsLock] as the switch key, nor addressing "mode errors" (ie. when the switch key is pressed multiple times).

Disclaimer: I am the developer of the Quick Lang Switch...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .