0

first time using Ubuntu after being on other distros for a while. Loving it so far, except for one big issue with suspend to RAM.

I've been digging around for solutions and can't seem to find anything. I've been combing through kernel logs and dmesg logs to find some information, but there isn't much. I did try one test and found the following:

  1. I suspended the laptop by closing the lid (confirmed with the power LED flashing)
  2. I resumed the laptop by opening the lid (confirmed with the power LED going to steady)
  3. Upon resume, nothing appeared on the screen, not even the backlight
  4. After waiting for about ten seconds, including trying keyboard input, I forced shutdown using the power button

I went looking through /var/log/kern.log and found this entry. This seemed to be the last entry made before the laptop suspended; the next entry was the start of the boot sequence:

Oct 26 18:29:53 martin-thinkpad kernel: [ 2443.966967] ahci 0000:00:17.0: port does not support device sleep

Any ideas on where to go next to figure out the root of the problem? Additional device info below:

Laptop: Lenovo Thinkpad 13 2nd generation Graphics: Intel integrated Kernel: 4.13.0-16-generic Ubuntu: 17.10 Artful

  • I've been having a similar problem on my desktop, however my laptop is fine resuming from suspend (both are on 17.10). Have you tried logging the suspend resume process with these instructions. – labarna Oct 27 '17 at 21:37
  • @labarna I had not tried doing that. I just did so; curiously, this time when I resumed, the screen came back up but was totally frozen. Shall I upload the log contents somewhere? – Martin Oct 27 '17 at 22:27
  • See if you can emend your original question with the new information. – labarna Oct 28 '17 at 1:43
  • I'm struggling with the same thing on my Dell XPS13. Started a few months ago and I find it pretty crippling to not be able to suspend or hibernate the laptop and travel with it. This is the only bug I've found that might be the issue but it's still open. bugs.launchpad.net/ubuntu/+source/linux/+bug/1740175 I'd suggest subscribing or clicking the "affects me" link to raise the heat of the bug. – Dan Feb 15 '18 at 2:52
  • Actually, I believe this bug is really what we're all experiencing... bugs.launchpad.net/ubuntu/+source/linux/+bug/… – Dan Feb 15 '18 at 3:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.