1

Thanks in advance for any help you guys can provide.

I have a Toshiba L50-B-243. I installed Ubuntu 17.10 choosing to erase the entire disk and previous partitions (Windows 10 & KDE Neon).

After install I got the dreaded "No bootable device - please restart" message. Using the Live USB I ran boot-repair, but it told me there was an error when repairing. Here is the log: http://paste.ubuntu.com/25825329/

I've tried re-installing from the Live USB to no avail. I've checked the BIOS menu and SecureBoot is definitely inactive, and in the config menu UEFI is selected. I've double-checked that the Live USB is definitely using EFI.

I have found another error but I don't know if it is related: I am unable to save any changes made in the BIOS menu - after restart all the changes have reverted. The only things that successfully save between restart are changes to time and date.

Any help you can provide would be greatly appreciated as my laptop is basically a brick at the moment.

EDIT:

I've tried several more things based off suggestions from around the web, but each solution hits an error :-(

First, I tried to manually update grub using: sudo update-grub /dev/sda

and I receive this message: /usr/sbin/grub-probe: error: failed to get canonical path of `/cow'

Next I ran efibootmgr and found out that: BootCurrent: 0000 Timeout: 0 seconds BootOrder: 2001,0004,0003,2003,2002 Boot0000* EFI USB Device (SanDisk) Boot0001* Realtek PXE Boot0002* Realtek PXE Boot0003* Windows Boot Manager Boot0004* ubuntu Boot2001* EFI USB Device Boot2002* EFI DVD/CDROM Boot2003* EFI Network

So following advice from another answer on askubuntu I tried to change the boot order (sudo efibootmgr -o 4,0,3) so it would load ubuntu first and got this error: Could not set BootOrder: Interrupted system call

If anyone has any more suggestions, I'd appreciate hearing them. Thanks again for any help!

EDIT: So, tried a solution to the "failed to get canonical path /cow" error, got a different error instead...

ubuntu@ubuntu:~$ sudo mount /dev/sda2 /mnt ubuntu@ubuntu:~$ sudo mount /dev/sda1 /mnt/boot ubuntu@ubuntu:~$ sudo grub-install --root-directory=/mnt /dev/sda Installing for i386-pc platform. grub-install: warning: this GPT partition label contains no BIOS Boot Partition; embedding won't be possible. grub-install: warning: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged.. grub-install: error: will not proceed with blocklists

Could it be there is something wrong with my hardware at this point? I've tried so many proposed solutions to this problem, with each solution simply presenting a new error that needs to be fixed. Is my whole laptop junk?

Final edit:

So I've now tried all the relevant solutions I can find on askubuntu (and the rest of the web) some of which appear to have completed successfully. However, as soon as I reboot, I get right back to the "no bootable device" screeen.

By adding '--force' I managed to get grub to update and install - no change.

I created a new Ubuntu 17.10 Live USB using the Ubuntu Startup Disk Creator on a new pendrive, but my laptop will not boot from it (same screen as always "no bootable device"). Then, I used Etcher to create a new KDE Neon Live USB on the new drive, but my laptop will not even start that (still claims there is no bootable device).

The only thing I can do is load up the Live USB that I originally used to install Ubuntu.

What has happened to my laptop? I'm really out of ideas and options now. Please, anybody that can help, please help me!

  • I had a Toshiba (different model). It required a system recovery partition (ntfs format) to be first on the internal disk, and the EFI system partition (FAT32 format) to be second. – ravery Oct 27 '17 at 0:36
  • Thank you for this information! I shall try to create a recovery partition - do you know what size it needs to be and if I need to install data on it? – Avi Oct 27 '17 at 8:50
  • In my case, I used the recovery DVDs to partition the drive, then deleted all but the recovery partition. Then installed to the free space. I do not remember if there were files in the recovery partition or not. – ravery Oct 27 '17 at 8:54
  • Thanks for your reply - unfortunately I have no recovery dvds :'-( – Avi Oct 27 '17 at 10:13
  • create a 1GB ntfs partition flagged as system recovery. and try. NOTE: if your EFI Firmware doesn't allow OS selection for boot, then Grub needs to be copied to the default media path( efi/boot/bootx64.efi) for device boot. – ravery Oct 27 '17 at 10:37
0

So eventually I found that answer, following the instructions here:

https://www.linux.com/learn/how-rescue-non-booting-grub-2-Linux

I have been able to log into my Ubuntu 17.10 OS on my hard drive. Unfortunately, so far I've found no way to make these changes permanent, so I have to follow this procedure every time I want to boot into my computer, but at least it's better than the alternative of have no computer at all.

I strongly advise anyone in a similar situation to follow the above instructions and to NEVER, ever by a Toshiba laptop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.