2

I have VMware Workstation 14 installed in Ubuntu 16.04. I created a new Fedora virtual machine allotting 1 GB RAM. I have 2 GB free available RAM and 4 GB free swap memory, but when i power on machine then it shows me error.

Not enough physical memory is available to power on this virtual machine with its configured settings. It is possible that native applications and/or services have locked down memory which could be preventing the virtual machine from launching. Shutting down unnecessary applications or services may free enough memory to launch this virtual machine. If you were able to power on this virtual machine on this host computer in the past, try rebooting the host computer. Rebooting may allow you to use slightly more host memory to run virtual machines.

I tried windows 7 and other operating systems too by increasing or decreasing allocated RAM size, restarting the host machine but got same error. But when i install VMware Workstation 12 it works fine. I am facing problem with VMware Workstation 14.

Any solution ?

6
  • Try giving it less than half of the total RAM. 2GB is not enough to run a Kali host and a Ubuntu guest in any decent way. – user692175 Oct 26 '17 at 16:31
  • @MichaelBay Did you read it carefully , i wrote "I have 2 GB free RAM available". Total RAM is 4GB and more than 2GB is free. – Sanjay Prajapat Oct 26 '17 at 16:33
  • @Sanjay Prajapat Might want to check requirements for what you're trying to do...Both of your OS's want 2GB, and that's not counting anything else running on the machine (VMWare, browsers, etc). Might be able to run it if you can boot without GUI on one or both, though seeing if you get get RAM added would be a much better solution - assuming you Kali install is x64. – s1ns3nt Oct 26 '17 at 18:24
  • @s1ns3nt I have tried some lightweight os like lubuntu, i am getting same error. – Sanjay Prajapat Oct 27 '17 at 11:57
  • I have the same issue, but i have over 10gb free for a 2gb guest vm? – jbbiomed Oct 31 '17 at 6:45
5

I fixed it based on this post by izznogooood:

sudo sucd /tmp
cp /usr/lib/vmware/modules/source/vmmon.tar .
tar xf vmmon.tar
rm vmmon.tar
wget https://raw.githubusercontent.com/mkubecek/vmware-host-modules/fadedd9c8a4dd23f74da2b448572df95666dfe12/vmmon-only/linux/hostif.c
mv -f hostif.c vmmon-only/linux/hostif.c 
tar cf vmmon.tar vmmon-only
rm -fr vmmon-only
mv -f vmmon.tar /usr/lib/vmware/modules/source/vmmon.tar 
vmware-modconfig --console --install-all

Another tip you should follow if you run intels onboard graphics is to enable 3D accelleration (adjust GFX memory to the guest machine accordingly) like a 7500U cpu is more than powerful enough for that. VMware does not allow this by default.

add:

mks.gl.allowBlacklistedDrivers = TRUE
2
  • Can you explain what's the problem and what are you trying to do ? – Sanjay Prajapat Nov 24 '17 at 13:51
  • Sanjay Prajapat, this is a bug in VMWare, the solution provided by bummi is a source code level fix. I've verified his solution fixed my problem – Clock ZHONG May 11 '18 at 16:35
0

Since newer version of ubuntu do not use swap partitions anymore,

Just make a bigger swap file:

  1. Make all swap off

sudo swapoff -a

  1. Resize the swapfile

sudo dd if=/dev/zero of=/swapfile bs=1M count=8192

  1. Make swapfile usable

sudo mkswap /swapfile

4.Make swapon again

sudo swapon /swapfile

2
  • I have the same problem and it is definitely not related to memory: I have 6 GB real RAM and 16 GB swap space and even the "minimum" virtual machine possible with VMware (4 MB RAM) prints this error message. – Martin Rosenau Nov 1 '17 at 15:35
  • 2
    This isn't a solution. I already have a working swap partition of 4GB. – Sanjay Prajapat Nov 1 '17 at 16:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.