3

I'm trying to install Vulkan on Ubuntu 17.10.

So far I've tried:

sudo apt install mesa-vulkan-drivers vulkan-utils

This does not appear to work, since I get the following output from vulkaninfo:

===========
VULKAN INFO
===========

Vulkan API Version: 1.0.42

INFO: [loader] Code 0 : Found manifest file /home/<redacted>/.local/share/vulkan/implicit_layer.d/steamoverlay_i386.json, version "1.0.0"
INFO: [loader] Code 0 : Found manifest file /home/<redacted>/.local/share/vulkan/implicit_layer.d/steamoverlay_x86_64.json, version "1.0.0"
INFO: [loader] Code 0 : Found ICD manifest file /etc/vulkan/icd.d/intel_icd.i686.json, version "1.0.0"
ERROR: [loader] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_intel.so: cannot open shared object file: No such file or directory
INFO: [loader] Code 0 : Found ICD manifest file /etc/vulkan/icd.d/radeon_icd.x86_64.json, version "1.0.0"
INFO: [loader] Code 0 : Found ICD manifest file /etc/vulkan/icd.d/intel_icd.x86_64.json, version "1.0.0"
INFO: [loader] Code 0 : Found ICD manifest file /etc/vulkan/icd.d/radeon_icd.i686.json, version "1.0.0"
ERROR: [loader] Code 0 : /usr/lib/i386-linux-gnu/libvulkan_radeon.so: cannot open shared object file: No such file or directory
INFO: [loader] Code 0 : Found ICD manifest file /usr/share/vulkan/icd.d/radeon_icd.x86_64.json, version "1.0.0"
INFO: [loader] Code 0 : Found ICD manifest file /usr/share/vulkan/icd.d/intel_icd.x86_64.json, version "1.0.0"

Instance Extensions:
====================
Instance Extensions count = 6
    VK_KHR_surface                      : extension revision 25
    VK_KHR_xcb_surface                  : extension revision  6
    VK_KHR_xlib_surface                 : extension revision  6
    VK_KHR_wayland_surface              : extension revision  5
    VK_KHR_mir_surface                  : extension revision  4
    VK_EXT_debug_report                 : extension revision  5
/build/vulkan-WFoCfr/vulkan-1.0.42.0+dfsg1/demos/vulkaninfo.c:1523: failed with VK_ERROR_INITIALIZATION_FAILED

Here's the output from lscpi:

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] [1002:665f] (rev 81)

Specifically, my graphics card is a Radeon R7 360.

Is there something I need to do to activate the drivers? It feels like I'm missing something super obvious...

3 Answers 3

3

Check this post. I had simmilar issue on my ATI Sapphire 7870 AND AMD Radeon 7870. (☞゚ヮ゚)☞

I believe that it could be an issue with amdgpu not loaded try to verify it using lspci -k | grep "Kernel driver in use:".

Output should be "Kernel driver in use: amdgpu".

If not Add NAND modify /etc/X11/xorg.conf with

Section "Device"
    Identifier "AMD"
    Driver "amdgpu"
    Option "TearFree" "true"
EndSection
  • Option "TearFree" "true" should fix problem with screen thearing.

Then modify /etc/default/grub as:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.si_support=0 amdgpu.si_support=1"

finished with sudo update-grub && sudo shutdown -r to update grub and restart your device.

Then i would suggest sudo usermod -a -G video $LOGNAME its recommended by AMD to fix this VK_ERROR.

Eventually i would suggest you to try hexchat on #radeon they should be able to help you.

2
  • Thanks for you answer. I don't think my card is supported by AMDGPU, since whenever I try to install it, X can't start.
    – fluffels
    Jun 4, 2018 at 10:16
  • i would try it anyway with those grub modifications radeon.si_support=0 amdgpu.si_support=1 and if it doesn't work then switch radeon.si_support=1 amdgpu.si_support=0. nor ask on #radeon IRC channel. I believe that your GPU is supported. (don't forget to run sudo update-grub after each modification.) Jun 5, 2018 at 6:41
1

Do you have the package libvulkan1 installed as well? That's the loader library, and should have the correct ICD JSON files to point to the proper loader.

edit: Also why don't you have API version 1.0.61?

Suggested fix for AMD: https://askubuntu.com/a/970377/750714

related: https://askubuntu.com/a/967910/750714

7
  • libvulkan1 appears to be pulled in by the packages above
    – fluffels
    Oct 31, 2017 at 9:07
  • API version is the one packaged with Ubuntu 17.10
    – fluffels
    Oct 31, 2017 at 9:08
  • /usr/share/vulkan/icd.d/radeon_icd.x86_64.json had "api_version": "1.0.3", fixed to 1.0.42, but no change
    – fluffels
    Oct 31, 2017 at 9:10
  • library_path is /usr/lib/x86_64-linux-gnu/libvulkan_radeon.so, which is correct for my machine, since that file exists
    – fluffels
    Oct 31, 2017 at 9:11
  • I also don't have this file /usr/share/vulkan/icd.d/radeon_icd.i686.json could that be a problem?
    – fluffels
    Oct 31, 2017 at 9:11
1

I suspect this card is just not supported by RADV at the moment.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .