On Ubuntu 17.10, Pulseaudio don't start at boot, but when I start it manually a few times, it works !? I tried pulseaudio -vv : https://pastebin.com/nZRwGR7z

  • I tried pulseaudio -vv : (pastebin.com/nZRwGR7z) – Gilbert Oct 26 '17 at 9:01
  • You know that you can edit your question and add this information in? Instead of putting it in a comment, which is often not been read when people look first glance at your question. – Videonauth Oct 26 '17 at 12:03
  • In the same boat – Aaahh Nov 16 '17 at 5:42

You might have to add it to systemd startup

systemctl --user enable pulseaudio && systemctl --user start pulseaudio

The flags can be configured (from the manual):

Depending on whether --system, --user, --runtime, or --global is specified, this enables the unit for the system, for the calling user only, for only this boot of the system, or for all future logins of all users, or only this boot.

| improve this answer | |
  • This is a defect IMO. Desktop configurations should have audio enabled by default. I end up having to have a workaround startup script check for it being disabled and re-enabling it lest it become disabled upon the next Ubuntu install from scratch. See askubuntu.com/a/962926/340383 – bgoodr Feb 4 '18 at 17:16

I had the same problem pulseaudio daemon not starting with Kubuntu 17.10 on my Asus laptop. What I found is that module module-switch-on-connect.so failed to load using pulseadio -vv command as user.

Commented out module-switch-on-connect.so from /etc/pulse/default.pa and this fixed my problem.

### Use hot-plugged devices like Bluetooth or USB automatically (LP: #1702794)
#.ifexists module-switch-on-connect.so
#load-module module-switch-on-connect

In your pastebin file I do not see an error not able to load a module by the way.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.