9

On Ubuntu 17.10 using Nvidia Quadro M2000, when the (external) screen stops consuming the DisplayPort data stream (either because the screen is turned off or a different input is chosen on the screen in order to view the desktop of another computer connected to the same screen), the graphical session is terminated, including all processes that were started from the graphical session.

This happens both with Nouveau (both Wayland and X) and with the Nvidia proprietary driver (nvidia-384).

This didn't happen with Ubuntu 16.04 and doesn't happen with Windows or Mac.

Terminating the graphical session like this is, obviously, extremely undesirable.

How can I make Ubuntu 17.10 not terminate the graphical session when the screen stops consuming the DisplayPort data stream?

6
  • 1
    I would stay with or return to 16.04 LTS, where the graphics work. 17.10 is a short-life version (supported for only 9 months). We can expect that this problem will be solved in the next LTS version, 18.04 to be released in April 2018. But before leaving 17.10, it would help if you write a bug report to Launchpad.
    – sudodus
    Commented Oct 26, 2017 at 8:03
  • 1
    Nouveau in 16.04.1 only supported 2D with this GPU. Nouveau in 17.10 supports 3D but isn't stable. Nouveau froze in the releases in between. The problem with 16.04 is that if the Nvidia proprietary driver falls out of use and nouveau has rolled forward, the system becomes unbootable. With 17.10, if the Nvidia proprietary driver falls out of use due to a kernel update, I can at least see something with Nouveau.
    – hsivonen
    Commented Oct 26, 2017 at 8:12
  • I see. So there are advantages with 17.10 and your graphics card. Well, maybe it is best to stay with 17.10 and spend some effort on a bug report in order to start the process to squash this bug (that the graphical session is terminated). If you are lucky, some other users with the same graphics will raise the heat of the bug report.
    – sudodus
    Commented Oct 26, 2017 at 8:49
  • 1
    The same happens to me. Any luck in fixing this?
    – Qerubin
    Commented Oct 27, 2017 at 7:33
  • I switched back to 16.04 and placed an order for an AMD GPU. Hoping that the Nvidia drivers on 16.04 don't melt down again before the AMD GPU arrives.
    – hsivonen
    Commented Oct 28, 2017 at 17:07

2 Answers 2

3

I heard from a duplicate question that you can work around this by locking your screen (Super+L) (that's the "windows" or "command" key, plus L) before turning off the display.

1
0

Managed to solve this problem by installing GNOME Tweaks from the Ubuntu Software Centre.

Within GNOME Tweaks there is a 'Power' menu with the option to 'Suspend when laptop lid is closed'

Disabled this option - problem solved.

Hope this helps

1
  • It didn't work on Ubuntu 17.10
    – salep
    Commented Apr 10, 2018 at 12:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .