4

I think I've encountered a bug with the nvidia drivers in Ubuntu 17.10.

When I remove nvidia-384 using sudo apt remove nvidia*, colord seems to stop being able to detect my monitor.

I reinstalled nvidia-384 and I noticed this error while it tried to reinstall:

dpkg: error: version '-' has bad syntax: revision number is empty

I'm not sure what it means, but here's a snippet of my terminal during the install:

update-alternatives: using /usr/share/nvidia-384/glamor.conf to provide /usr/share/X11/xorg.conf.d/glamoregl.conf (glamor_conf) in auto mode
dpkg: error: version '-' has bad syntax: revision number is empty
update-initramfs: deferring update (trigger activated)
INFO:Enable nvidia-384

This is the second time I've gotten that error, after reformatting 17.10 a couple of days ago. 'colormgr get-devices' returns no devices.

Also 'colormgr create-device D2757 temp display' returns:

could not check org.freedesktop.color-manager.create-device for auth: GDBus.Error:org.freedesktop.PolicyKit1.Error.NotAuthorized: Only trusted callers (e.g. uid 0 or an action owner) can use CheckAuthorization() for subjects belonging to other identities

That's as far as I can go with this problem. I'm out of my depth in resolving it any further.

  • 5
    The dpkg error is from a typo in the install script. You can correct it by editting /var/lib/dpkg/info/nvidia-384.postinst find $KERNELS (line# 208) replace with $CURRENT_KERNEL You can then reconfigure: sudo dpkg-reconfigure nvidia-384. Re-installing would overwrite this editted file. – OttoV Oct 30 '17 at 18:43
0

Did you try with the --purge option when you remove your nvidia driver? It will also delete configuration files. If it don't work you can try:

sudo apt-get install lightdm
sudo dpkg-reconfigure gdm

as said in another post

  • Oh thanks. Interesting: sudo dpkg-reconfigure gdm gives: dpkg-query: package 'gdm' is not installed and no information is available And it also appears that lightdm isn't installed. In which case, how the heck did I just log into my ubuntu session? :P Is 17.10 using a special display manager? – Damon Oct 26 '17 at 7:41
  • Here's what I get when trying to install gdm: Package gdm is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source However the following packages replace it: cinnamon-control-center-data – Damon Oct 26 '17 at 7:43
  • Ok, so apparently now days you have to type sudo dpkg-reconfigure gdm3. As opposed to sudo dpkg-reconfigure gdm. I also tried installing and using lightdm. Unfortunately it doesn't seem to have any effect on the colord issue yet. 'colormgr get-devices' still comes back blank, and 'colormgr create-device D2757 temp display' still gives me the permissions error. 'sudo colormgr create-device D2757 temp display' succeeds, but I still don't get any output of 'colormgr get-devices' after. Nor with 'sudo colormgr get-devices'. – Damon Oct 26 '17 at 8:10
  • So I'm all out of ideas, appart from maybe purging and reinstalling the nvidia driver while using lightdm. Which I'll try, but doubt it will work. – Damon Oct 26 '17 at 8:10
0

I had the same error and for me installing "nvidia-384-dev" seemed to solve the problem... (Maybe, something is wrong with dependencies?)

sudo apt install nvidia-384-dev

sudo apt install --reinstall nvidia-384

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.