I own a Samsung M2070W printer/scanner, which worked in 17.04. After installing 17.10, it prints but is not detected my Simple Scan or Xsane.

The latest drivers from the Samsung website are installed.

It is detected by sane-find-scanner but not scanimage-L. Output from the former:

found USB scanner (vendor=0x04e8 [Samsung Electronics Co., Ltd.], product=0x3469 [M2070 Series]) at libusb:003:003

I tried modifying the .bashrc as suggested in Samsung SCX-4200 Scanner not working (printing OK) 14.04, but it didn't work.

I've seen this issue on several forums but no one seems to have a solution.

  • Sorry, but I'm not tech-savvy enough to know what to do with that information? Does it mean the bug is now fixed? – Lolwhites Oct 29 '17 at 19:57
  • it means that many people do have this problem and it is not fixed. somebody changed something, did not test it very well, and thousands of users cannot scan now. – jms Oct 31 '17 at 9:45

See the bug report of this problem and the workaround that I posted in that bug report. Let me sum it up here to help you out:

  1. Link the files libsane-smfp* in the sane folder found at /usr/lib/sane to the sane folder found at /usr/lib/x86_64-linux-gnu/sane.

    sudo ln -sfr /usr/lib/sane/libsane-smfp* /usr/lib/x86_64-linux-gnu/sane
    
  2. As root, edit the file 59-smfp_samsung.rules (you can find it in /etc/udev/rules.d) to include the following code/scanner number along with other Samsung model numbers which are already there:

    ATTRS{idProduct}=="2070", ENV{libsane_matched}="yes"
    

Voila. It should work like a charm.

I believe this bug mostly affects network scanners. Except with minor variations in the name/model numbers of other scanners, this workaround should work for other network scanners too. Check the bug-report link for Brother, Epson, and Xerox scanners.

  • 1
    I tried this solution but it wont work with my scanner over wifi. – Francisco V. Mar 16 at 9:34
  • 1
    Thanks a lot for this solution. This made my Samsung SCX-3205W scanner connected over Wi-Fi work in Ubuntu 18.04. – Maxim Egorushkin May 4 at 23:45

I just got the scanner from Samsung M2070FW running with Ubuntu 18.04. Just follow these steps:

  1. Get UnifiedLinuxDriver-1.00.37.tar.gz from this site and unpack it, open a terminal and do:

    cd /UnifiedLinuxDriver-1.00.37/uld
    sudo ./install.sh
    
  2. After successful installation of the Samsung Driver for the printer and the scanner, you can installer the printer first via Cups. For the scanner however, there should be a new directory with a single file in it:

    /opt/smfp-common/scanner/lib/libsane-smfp.so.1.0.1
    
  3. If you use a 64-bit system (which you probably do), use the terminal again to change to the scanner driver directory. Here you put a symbolic link to the file in /opt:

    cd /usr/lib/x86_64-linux-gnu/sane
    sudo ln -s /opt/smfp-common/scanner/lib/libsane-smfp.so.1.0.1 /usr/lib/x86_64-linux-gnu/sane/libsane-smfp.so.1
    
  4. But things still didn't work, so I had to install a USB library:

    sudo apt install libusb-0.1-4
    

    After that, I made sure that I was in the same network with my printer (via ping) and did scanimage -L:

    $ scanimage -L
    device `smfp:net;192.168.1.20' is a Samsung M2070 Series on 192.168.1.20 Scanner
    
  5. If pinging your scanner works but the command finds nothing, you can start to debug things:

    cd
    export SANE_DEBUG_DLL=255 && scanimage -L &> debug.txt
    grep -n2 "libsane-smf" debug.txt
    

    If everything works correctly, you would get the following output:

    ....
    84-[dll] sane_get_devices
    85-[dll] load: searching backend `smfp' in `/usr/lib/x86_64-linux-gnu/sane'
    86:[dll] load: trying to load `/usr/lib/x86_64-linux-gnu/sane/libsane-smfp.so.1'
    87:[dll] load: dlopen()ing `/usr/lib/x86_64-linux-gnu/sane/libsane-smfp.so.1'
    88-[dll] init: initializing backend `smfp'
    89-[dll] init: backend `smfp' is version 1.0.1
    ....
    

    If not, you might find a hint as to what file is missing or not found.

  • Did everything you described, and I get the same output as you do in step 5. The scanner works, after a fashion - Simple Scan does one page fine, but hangs on the second. However, it's fine if I run it in a terminal. – Lolwhites Jun 28 at 9:53
  • This worked for my Samsung Express C460FW. Thank you! – Artelius Sep 9 at 2:10
  • Hi. I have Lenovo B50 Laptop with Ubuntu 18.04 and Samsung Xpress M2070W. Your scanner stuff saved my day, Thank you. – Garrom Sep 18 at 14:28

For a Samsung Scanner/Printer M2885FW, which is connected over WiFi, and Ubuntu 18.04 a combination of two suggestions in this thread solved the problem with scanning: Rajasekharan N.'s answer and Jevgenij Evll's answer.

  1. I rebuilt the links found at /usr/lib/sane in the folder /usr/lib/x86_64-linux-gnu/sane by using following lines:

    sudo ln -s /opt/smfp-common/scanner/lib/libsane-smfp.so.1.0.1 /usr/lib/x86_64-linux-gnu/sane/libsane-smfp.so.1.0.1
    sudo ln -s /usr/lib/x86_64-linux-gnu/sane/libsane-smfp.so.1.0.1 /usr/lib/x86_64-linux-gnu/sane/libsane-smfp.so.1
    sudo ln -s /usr/lib/x86_64-linux-gnu/sane/libsane-smfp.so.1 /usr/lib/x86_64-linux-gnu/sane/libsane-smfp.so
    
  2. After this step I un- and reinstalled the Samsung drivers.

  • Hi Marion! In your answer, can you include link(s) to the questions/answers that helped you? – Hee Jin May 7 at 16:04
  • The scanner is now detected by both Xsane and Simple Scan. However when I try to actually scan, Xsane returns the message "Failed tro start scanner: Error during device I/O" while Simple Scan says "Failed to start scan". Running in a terminal provides no information. – Lolwhites May 8 at 19:15
  • @Lolwhites. Have you tried to run xsane as a root to check if your problem could be a permission issue? – Marion Sr May 15 at 11:42
  • I found that plugging the scanner directly into a USB port instead of via a hub solved many of the issues, but I can still can't scan multiple pages. – Lolwhites May 16 at 14:55

For network Samsung scanners, put your scanner's IP address and optionally port anywhere in the file /etc/sane.d/xerox_mfp.conf:

tcp host_address [port] 

It worked with my C460, probably would work also with other scanners, check the respective sane config file and settings here:

  • Mine is connected by USB. How do I find out the relevant information? – Lolwhites Mar 18 at 18:47
  • Here is a good starting point for the usb configurationt: systutorials.com/docs/linux/man/5-sane-usb – iipavlov Mar 20 at 1:35
  • that worked for me (without installing the Samsung driver), except that the printer/scanner is now waking up every time I start the system or plug in a USB device – Damien May 11 at 21:42
  • Excellent, this worked for me with a Samsung SCX-3405FW wifi printer and scanner. and I'm on a new install of Ubuntu 18.04 – Julio Aug 3 at 10:24

For my SAMSUNG M2070 running uninstall-scanner.sh and then install-scanner.sh again (with restarting afterwards) fixed the issue. I also installed libsane and sane-utils from the proposed updates repo prior to the above, but not sure if this step is needed.

  • 1
    Uninstalling and reinstalling the driver didn't fix teh issue. I tries to get the latest version of sane via the ppa rolfbensch/sane-git androlfbensch/sane-release but the upgrade is held back. – Lolwhites Nov 12 '17 at 19:51
  • Use the official aartful-proposed repo for getting the newer sane version (you can enable this repo in settings). – Jevgenij Evll Nov 13 '17 at 9:31
  • I removed the ppa and enabled the repo but the upgrade was still held back. I ran apt install libsane-common libsane-dev sane-utils and it worked, but now running Simple Scan causes a segfault and other programs like Xsane won't install because of dependency issues. – Lolwhites Nov 16 '17 at 16:08
  • You don't need to install lisane-dev, but you need to install libsane1 from the experimental repo. – Jevgenij Evll Nov 17 '17 at 8:43
  • Actually, the latest libsane version has been released to updates 2 days ago, so you might get it from your regular repo. – Jevgenij Evll Nov 17 '17 at 8:46

I tried Rajasekharan N.'s solution with Ubuntu 18.04 for Samsung 2070w and the newest uld driver downloaded from hp - scanner didn't work even connected via USB cable.

So

  1. I removed the uld driver using the uninstall.sh provided with the uld driver
  2. I reinstalled using the older Samsung uld driver (sadly I have no link for it) and it works again

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.