1

I started to get s trange message while running the backup procedure. At the end it says that the backup failed with the following error: "Backup location /tmp/duplicity-bghuvg-tempdir/mktemp does not exist."

The only thing that is close to it that I found is in this topic: http://ubuntu.5.x6.nabble.com/Backup-fails-td5112049.html

i've already tried to delete old backups and start a new one, I tried to clear the deja-dup cache and start new backups but it does not help.

Any suggestions on how to solve th problem?

I'm using an external server (access over SSH), it has enough space (1TB), the backup starts every week (but I also tried to start it manualy and it does not help), the only folder that is backed up is the home folder of a user with an ignore on "Trash" and "Downloads" (the default settings).

I got this message on 17.04 and did an upgrade to 17.10 it did not solve the problem either.

  • Welcome to Ask Ubuntu! :-) Looks like a permissions issue as per the thread you already found. What does mkdir /tmp/duplicity-bghuvg-tempdir/mktemp do? (DO NOT use sudo) – Fabby Oct 27 '17 at 10:19
  • Hello, well, this command creates a directory in /tmp, which does not help, because duplicity creates a fresh new one every time with a different name in the /tmp like "duplicity-I5hv36-tempdir" instead of "duplicity-bghuvg-tempdir". – user8833765 Oct 28 '17 at 10:37
  • ok, so creating the directory manually seems to work... Out of ideas... – Fabby Oct 28 '17 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.