1

I use Gnome-Ubuntu, and just upgraded from 17.04 to 17.10. A very strange thing happens since: when I open a session, some applications have the correct (French, in my case) keyboard layout, but others don't (they have a Qwerty layout, I assume this is system default). It seems to be GTK (correct) vs. non-GTK (incorrect).

The fix is quite simple, but strange: I have to switch to another virtual terminal (CTRL+ALT+Fn), and back to my Gnome session, and all applications are now using a French layout... :-/

The problem seems to be related to Wayland; GTK does not have it.

Also, when I open the "Input Method" settings, here is what I have:

Current configuration for the input method:
 * Active configuration: ibus (normally missing)
 * Normal automatic choice: ibus (normally ibus or fcitx or uim)
 * Override rule: 
 * Current override choice:  (en_US)
 * Current automatic choice: ibus
 * Number of valid choices: 2 (normally 1)
The override rule is defined in /etc/default/im-config.
The configuration set by im-config is activated by re-starting X.
Explicit selection is not required to enable the automatic configuration if the active one is default/auto/cjkv/missing.
Available input methods: ibus xim
Unless you really need them all, please make sure to install only one input method tool.

Could this be related?

Edited: also, here are some related info about my configuration:

$ gsettings get org.gnome.desktop.input-sources sources

[('xkb', 'fr+oss')]

$ cat /etc/default/keyboard

# KEYBOARD CONFIGURATION FILE
# Consult the keyboard(5) manual page.
XKBMODEL="pc105"
XKBLAYOUT="fr"
XKBVARIANT="oss"
XKBOPTIONS=""
BACKSPACE="guess"
3
  • What does the command gsettings get org.gnome.desktop.input-sources per-window output? – Gunnar Hjalmarsson Oct 25 '17 at 19:11
  • it says "false" – Pierre-Antoine Oct 25 '17 at 22:28
  • Ok, thanks. Then can you please edit your question and show us the output of these two commands: 1. gsettings get org.gnome.desktop.input-sources sources 2. cat /etc/default/keyboard – Gunnar Hjalmarsson Oct 25 '17 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.