7

I upgraded system from 17.04 to 17.10. Sometimes after login to Gnome3 I dont see tray icons. And it looks like this:

enter image description here

Only standard Gnome applets are visible. After logout and login again it back to normal, like this:

enter image description here

5
  • Not really. I don't see any tray icons, Gnome and legacy icons either. – QkiZ Oct 26 '17 at 4:19
  • 4
    If the issue is resolved through logout-login, could you please try to reload Gnome Shell instead the next it happens? You can do that if you open its Run dialogue (Alt+F2), enter r and press Enter. Through the command lg you can also open Looking Glass which allows you to inspect the status and error log of all enabled Gnome Shell extensions. – David Foerster Oct 26 '17 at 7:32
  • Wow, I didn't knew that features. Thx for a tip. I will check it with lg – QkiZ Oct 26 '17 at 11:39
  • I made a reset of Gnome but it didn't help. Looking Glass didn't help, no errors. I will try to disable all extensions and try a reboot to see which cause problems. – QkiZ Oct 26 '17 at 15:14
  • Thanks @DavidFoerster. On my Gnome I used journalctl -xe | grep Extension to find culprit extension. – Noam Manos Mar 19 '18 at 22:06
6

Problem was in old Unity indicator-application. Because I used Unity earlier in 17.04 and upgraded to 17.10 this indicator wasn't removed. I still have Unity available. After disabling indicator-application from autostart now legacy tray icons works fine. To disable autostart of this indicator remove /etc/xdg/autostart/indicator-application.desktop file from system. Now it works with standard Ubuntu Appindicators Gnome extension.

4
  • after deleting that file, Should I run any command to open it again? – HMagdy Nov 16 '17 at 8:56
  • What you want to open? – QkiZ Nov 16 '17 at 10:01
  • I meant seeing my icons again as it was before upgrade, I fixed this by installing "TopIcons GNOME Shell Extension" now I have all icons at the top bar, Thanks dude – HMagdy Nov 16 '17 at 13:44
  • I installed this extension too but it is not updating any changes to tray icons if you still have Unity indicator-application. For example run Steam client or keepassxc with tray icon enabled and will not see icon in tray area. After restarting gnome-shell it will be but you need to restart gnome-shell to see changes made to tray. – QkiZ Nov 16 '17 at 19:39
4

The issue is caused by an old Unity app-indicator which is in the system autostart. Remove it with sudo apt remove indicator-application and reboot.

Only removing the config setting /etc/xdg/autostart/indicator-application.desktop as suggested in the another answer is not very clean and may cause issues later on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.