4

More than three times:

thufir@dur:~$ 
thufir@dur:~$ cat android
Script started on 2017-10-26 05:49:38-0700
thufir@dur:~$ 
thufir@dur:~$ umake -v android android-studio --accept-license
INFO: Logging level set to INFO
INFO: Create a new apt cache
INFO: clang isn't installed
INFO: openjdk-7-jdk isn't installed
INFO: openjdk-7-jdk isn't installed
INFO: Don't register Eclipse ADT as it's not installable on this configuration.
INFO: Don't register Dart Editor as it's not installable on this configuration.
INFO: libxtst6:i386 isn't installed
INFO: libxext6:i386 isn't installed
INFO: libxi6:i386 isn't installed
INFO: libxt6:i386 isn't installed
INFO: libxpm4:i386 isn't installed
INFO: libxmu6:i386 isn't installed
INFO: libgtk2.0-0:i386 isn't installed
INFO: libatk1.0-0:i386 isn't installed
INFO: libcairo2:i386 isn't installed
INFO: libexpat1:i386 isn't installed
INFO: libfontconfig1:i386 isn't installed
INFO: libfreetype6:i386 isn't installed
INFO: libglib2.0-0:i386 isn't installed
INFO: libice6:i386 isn't installed
INFO: libpango1.0-0:i386 isn't installed
INFO: libpng12-0:i386 isn't installed
INFO: libsm6:i386 isn't installed
INFO: libxau6:i386 isn't installed
INFO: libxcursor1:i386 isn't installed
INFO: libxdmcp6:i386 isn't installed
INFO: libxfixes3:i386 isn't installed
INFO: libx11-6:i386 isn't installed
INFO: libxinerama1:i386 isn't installed
INFO: libxrandr2:i386 isn't installed
INFO: libxrender1:i386 isn't installed
INFO: libnss3-1d:i386 isn't installed
INFO: libnspr4-0d:i386 isn't installed
INFO: libcurl3:i386 isn't installed
INFO: libasound2:i386 isn't installed
INFO: libpng12-0:i386 isn't available on this platform
INFO: libnss3-1d:i386 isn't available on this platform
INFO: libnspr4-0d:i386 isn't available on this platform
INFO: Don't register Stencyl as it's not installable on this configuration.
INFO: openjdk-7-jdk isn't installed
INFO: openjdk-7-jdk isn't installed
INFO: openjdk-7-jdk isn't installed
INFO: openjdk-7-jdk isn't installed
INFO: openjdk-7-jdk isn't installed
INFO: openjdk-7-jdk isn't installed
INFO: openjdk-7-jdk isn't installed
INFO: openjdk-7-jre isn't installed
INFO: openjdk-7-jre isn't installed
INFO: clang isn't installed
INFO: libicu-dev isn't installed
Choose installation path: /home/thufir/.local/share/umake/android/android-studio
INFO: Start downloading DownloadItem(url='https://developer.android.com/sdk/index.html', checksum=None, headers=None, ignore_encoding=False, cookies=None) in memory
INFO: https://developer.android.com/sdk/index.html download finished
INFO: All pending downloads for [DownloadItem(url='https://developer.android.com/sdk/index.html', checksum=None, headers=None, ignore_encoding=False, cookies=None)] done
INFO: Installation ['libncurses5:i386', 'libstdc++6:i386', 'zlib1g:i386', 'openjdk-8-jdk'] pending
INFO: Start downloading DownloadItem(url='https://dl.google.com/dl/android/studio/ide-zips/3.0.0.18/android-studio-ide-171.4408382-linux.zip', checksum=Checksum(checksum_type=<ChecksumType.sha1: 'sha1'>, checksum_value='7991f95ea1b6c55645a3fc48f1534d4135501a07b9d92dd83672f936d9a9d7a2'), headers=None, ignore_encoding=False, cookies=None) to a temp file
Downloading and installing requirements
ERROR: https://dl.google.com/dl/android/studio/ide-zips/3.0.0.18/android-studio-ide-171.4408382-linux.zip couldn't finish download: The checksum of https://dl.google.com/dl/android/studio/ide-zips/3.0.0.18/android-studio-ide-171.4408382-linux.zip doesn't match. Corrupted download? Aborting.
INFO: All pending downloads for [DownloadItem(url='https://dl.google.com/dl/android/studio/ide-zips/3.0.0.18/android-studio-ide-171.4408382-linux.zip', checksum=Checksum(checksum_type=<ChecksumType.sha1: 'sha1'>, checksum_value='7991f95ea1b6c55645a3fc48f1534d4135501a07b9d92dd83672f936d9a9d7a2'), headers=None, ignore_encoding=False, cookies=None)] done
100% |#####################################################################################|
ERROR: The checksum of https://dl.google.com/dl/android/studio/ide-zips/3.0.0.18/android-studio-ide-171.4408382-linux.zip doesn't match. Corrupted download? Aborting.
thufir@dur:~$ 
thufir@dur:~$ exit
exit

Script done on 2017-10-26 06:18:19-0700
thufir@dur:~$ 

Googling the checksum from the console gives this link:

Linux android-studio-ide-162.4069837-linux.zip 468 MB (490,782,431 bytes) 1383cfd47441e5f820b6257a1bdd683e0e980bc76c7f2027ef84dc2e6ad2f17f

https://developer.android.com/studio/index.html

which looks like it matches to me. So the error doesn't even make sense.

System info:

thufir@dur:~$ 
thufir@dur:~$ umake --version
16.11.1
thufir@dur:~$ 
thufir@dur:~$ cat /etc/lsb-release 
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=17.10
DISTRIB_CODENAME=artful
DISTRIB_DESCRIPTION="Ubuntu 17.10"
thufir@dur:~$ 
1
  • 1
    umake is buggy sometimes.
    – karel
    Oct 25, 2017 at 14:14

1 Answer 1

1

I have run into the same error attempting to install arduino IDE on Ubuntu 18.04:

umake ide arduino

Which failed with:

ERROR: The checksum of https://www.arduino.cc/download_handler.php doesn't match. Corrupted download? Aborting.

In my case the solution was to use the latest version of ubuntu-make from the PPA:

sudo add-apt-repository ppa:lyzardking/ubuntu-make
sudo apt update

Get rid of all the old stuff:

sudo apt purge ubuntu-make
sudo apt autoremove && sudo apt autoclean
rm -rf ~/.local/share/umake

And reinstall umake:

sudo apt install ubuntu-make

Then retry your umake install and you should be good to go.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .