Possible Duplicate:
How to get Broadcom BCM 43XX Wireless card working

Okay so I've this afternoon updated the family laptop to 11.10. But our broadcom BCM4313 wireless card has stopped working. I tried googling and found someone saying you have to install a deb named 'b43-fwcutter_014-9_i386' and select the new driver but the driver did not appear in my list.

The laptop is a compaq Cq56


lshw output http://pastebin.com/KNTj6fLt

rfkill 0: hp-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

it's worth noting that I've pressed the wireless key that usually turns the colour of a little light on the key from orange to white. But it just stays orange now. Also after plugging in an ether cable and selecting it from network manager I still can't access the Internet on the laptop. Though that problem existed even on 11.04 when the wireless worked.

Okay I installed a driver that was older then the current one that was in use. After rebooting several times the wifi is now back on. When I installed it and rebooted once it didn't work. Wonder why it did after I did rebooted several times?

For a moment I thought to install Windows. Don't judge me. I was weak. I don't know what came over me.

marked as duplicate by Luis Alvarado, belacqua, Thomas Ward, Ringtail, Takkat Nov 13 '12 at 14:52

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • you've got a hard-block - that means a physical switch is blocking, not software. This can be a Fn key, a slide switch or button. Some switches can be very discrete (under a battery for example). What is your laptop and its model? – fossfreedom Jan 19 '12 at 19:59

Please have a look to my answer on the following question

How do I get the Broadcom BCM4313 wireless working on an Asus 1015PX?

  • Tried several of those fixes. But no avail. – RADXack Jan 19 '12 at 19:29

PTbuntu answer does not do it for me, this one does http://drndivoje.wordpress.com/2011/07/31/how-to-enable-broadcom-wireless-bcm4311-card-on-linux-mint-11/

Not the answer you're looking for? Browse other questions tagged or ask your own question.