After upgrading to Artful, I can not get any virtual machine to work in VMplayer and when I try to run any of my old machines I get this message :

Not enough physical memory is available to power on this virtual machine with its configured settings. It is possible that native applications and/or services have locked down memory which could be preventing the virtual machine from launching. Shutting down unnecessary applications or services may free enough memory to launch this virtual machine. If you were able to power on this virtual machine on this host computer in the past, try rebooting the host computer. Rebooting may allow you to use slightly more host memory to run virtual machines.

N.B: Memory usage : 2.74G/7.67 (I have 8G of memory).

After that message is displayed the VMplayer crashes.

I have done some research in the Internet but most posts are treating this problem in Windows.
I tried this few solutions:

  • Searched for .lck files to remove them, find none.
  • Searched for .vmss files find and remove them all.
  • Edited all my .vmx files go to section checkpoint.vmState = "", and remove text between quotes.
  • And finally uninstall, purge and reinstall application. To unistall I find this command : sudo vmware-installer -u vmware-player because sudo apt-get remove VMplayer didn't do anything, and to reinstall i downloaded and ran the latest version : VMware-Player-14.0.0-6661328.x86_64.bundle.
  • Create new virtual machine.

None of the above solution seems to fix the problem, I am stuck with VirtualBox which I can't get USB to work again.

  • How much memory are you attempting to allocate to the VM? Oct 25 '17 at 12:08
  • Generally 1Gig, cause i use it to run Win Seven 32bits for compatibility reasons. Also, I can launch 3 or 4 virtual machines before upgrading, and i didn't change any of the configurations. I found this problem very popular in Windows, so I found lot of workarounds, changing some configuration files in VMplayer which I cannot find in Ubuntu, starting as administrator which I tried by launching VMplayer in SU mode, but it can't be helped, nothing works for me. Oct 25 '17 at 13:36
  • 1
    Did you find a solution eventually? I have the same problem, and the provided answer also does not work for me (same error as you mentioned in the comments)
    – TomTasche
    Oct 30 '17 at 10:53
  • I am stuck, since my upgrade to artful, neither vmplayer nor kile live preview are working, neither the compilation solution worked for me. Oct 30 '17 at 12:59

Based on this method, I've used the following commands to solve similar issue:

cd /tmp
git clone https://github.com/mkubecek/vmware-host-modules.git
cd vmware-host-modules
git checkout workstation-14.0.0
tar cf vmmon.tar vmmon-only
sudo cp vmmon.tar /usr/lib/vmware/modules/source
sudo vmware-modconfig --console --install-all

In this way it compiles and works correctly.

  • When running a script containing these lines I got the same error. When trying to run the same script with sudo command the compilation is "O.K" and I got my problem solved. Nov 5 '17 at 19:40
  • 1
    vmware-modconfig --console --install-all gives an error like "Failed to get gcc information. " on my computer Nov 8 '17 at 15:18
  • maybe you don't have installation tools. use apt-get install build-essential to install necessary packages. Nov 12 '17 at 10:06
  • I am having the same issue, but the build-essentials are installed.
    – tokam
    Jan 30 '18 at 15:21

Ok, here's how you do this: After installing VM Workstation Player 14 in Ubuntu 17.10, download this proper diff'd patch and save it to /tmp/hostif-fix.patch


Run the following as root (manually with sudo su, or in a .sh file run with sudo sh):

cd /usr/lib/vmware/modules/source
tar xf vmmon.tar
cd vmmon-only/linux
patch hostif.c /tmp/hostif-fix.patch
cd ../..
tar cf vmmon.tar vmmon-only
rm -rf vmmon-only 
vmware-modconfig --console --install-all

Works, tested on Ubuntu 17.10 with Workstation Player 14. Thanks to geneC for creating the working patch, and to Charles Green for identifying the original commit and procedure


Apparently this is a known issue with kernel 14.0 and above - there is a patch available at https://github.com/mkubecek/vmware-host-modules/commit/770c7ffe611520ac96490d235399554c64e87d9f

Instructions (adapted from Arch Linux)

cd /usr/lib/vmware/modules/source
tar xf vmmon.tar
cd vmmon-only/linux
vim hostif.c # or use the patch command to apply the patch
cd ../..
tar cf vmmon.tar vmmon-only
rm -rf vmmon-only # cleanup

# Lastly, we need to rebuild the patched module
sudo vmware-modconfig --console --install-all

Some references:

vmware community


A Windows host based VMWare solution

  • 2
    Can't compile, got this error : /tmp/modconfig-79T7MO/vmmon-only/linux/hostif.c:99:10: fatal error: vmmonInt.h: No such file or directory #include "vmmonInt.h" Oct 25 '17 at 14:12
  • 1
    K - you're probably going to need to go to the source on GitHub to get a better resolution on this - from what I read, they seem pretty active. Oct 25 '17 at 14:18

I was having the exact same issue - thanks @CharlesGreen for the answer!

As I'm running Workstation Player 14.0.0 simply replacing the file with the referenced patch won't do.

You have to actually replace the code in the extracted hostif.c. The referenced Patch was supplied for Workstation Player 12.5 and wont work for 14

  • 1
    That's exactly what I've done, and after replacing text in hostif.c, you have to compile again and there I got this error message : /tmp/modconfig-79T7MO/vmmon-only/linux/hostif.c:99:10: fatal error: vmmonInt.h: No such file or directory #include "vmmonInt.h. Nov 2 '17 at 14:47
  • to be very clear on this: have you replaced the entire content oh hostif.c or did you apply the the single changes of the patch?
    – joe
    Nov 3 '17 at 15:56
  • I replaced the entire content. Nov 5 '17 at 12:15
  • 1
    Only apply the sections changed in the referenced file. The referenced file is ment for Workstation Player 14 - it WILL NOT WORK with 14. The changes on the other hand will. here you find the file for Player 14 with the changes already applied
    – joe
    Nov 7 '17 at 6:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.