1

If firefox is connected to the internet and a page starts to load it crashes. Prefer Firefox (my fav browser) over others. Firefox is the default browser for Lubuntu.

Firefox crashes with Lubuntu 16.04. 17.04 or 17.10 installed or live CD. Other programs like lubuntu updates can use the internet just fine.

What I tried: Clean install. Safe mode, refresh, delete cache and cookies, different theme, different Ubuntu theme, command line firefox, new profile and sudo firefox. Turned off drivers, only one listed was micro codes - likely IBM. No change, still crashes.

Chromium crashes too. I have not reinstalled or downgraded Firefox.

The computer is an older ThinkPad A20p notebook - I set bios to factory defaults. Edimax usb wifi - works on many ubuntu systems out of the box easy including ubuntu 16.04.

Summery: If I disconnect from the internet Firefox runs and I can change preferences and such within Firefox. Seconds into loading a page after reconnecting it crashes. Disconnecting allows me to try different settings which is nice.

Details: Command line firefox (from installed version of Firefox)

firefox
ExceptionHandler::GenerateDump cloned child 1170
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...

firefox -safe-mode
    ExceptionHandler::GenerateDump cloned child 3893
    ExceptionHandler::SendContinueSignalToChild sent continue signal to child
    ExceptionHandler::WaitForContinueSignal waiting for continue signal...

The crash reporter gives a lot of technical info, anything in all that I should be looking for?

Does NOT work from liveDVD. In other words, it is the same, Firefox works. Connect to the net and immediate crash.

Running from the liveDVD: Examples leafpad and gnumeric and Disks alias gnome-disks all work - no crashes. Terminal: firefox Broken pipe errors and FileDecriptorSet destroyed.

Firefox Crash report info: (from installed version of Firefox)

Add-ons: shield-recipe-client%40mozilla.org:65,activity-stream%40mozilla.org:0.0.0,e10srollout%40mozilla.org:3.00,followonsearch%40mozilla.com:0.9.3,screenshots%40mozilla.org:10.12.0,onboarding%40mozilla.org:0.1,aushelper%40mozilla.org:2.0,firefox%40getpocket.com:1.0.5,webcompat%40mozilla.org:1.1,formautofill%40mozilla.org:1.0,clicktoplay-rollout%40mozilla.org:1.4,%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D:56.0,langpack-en-ZA%40firefox.mozilla.org:56.0,langpack-en-GB%40firefox.mozilla.org:56.0,ubufox%40ubuntu.com:3.3
AddonsShouldHaveBlockedE10s: 0
BuildID: 20171003222115
CTPCohort: user-changed-from-test
ContentSandboxCapabilities: 119
ContentSandboxCapable: 1
ContentSandboxLevel: 2
CrashTime: 1510859794
DOMIPCEnabled: 1
E10SCohort: addons-set50allmpc-test
EMCheckCompatibility: true
Email: ########@#######.###
FramePoisonBase: 0000004041121792
FramePoisonSize: 4096
InstallTime: 1508703061
Notes: Ubuntu 17.10FP(D00-L1000-W00000000-T000) OpenGL: VMware, Inc. -- llvmpipe (LLVM 5.0, 128 bits) -- 3.0 Mesa 17.2.2 -- texture_from_pixmap
WR? WR- 
ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
ProductName: Firefox
ReleaseChannel: release
SafeMode: 0
SecondsSinceLastCrash: 53886
StackTraces: 
StartupCrash: 0
StartupTime: 1510859765
TelemetryEnvironment: {"build":{"applicationId":"{ec8030f7-c20a-464f-9b0e-13a3a9e97384}","applicationName":"Firefox","architecture":"x86","buildId":"20171003222115","version":"56.0","vendor":"Mozilla","platformVersion":"56.0","xpcomAbi":"x86-gcc3","hotfixVersion":null},"partner":{"distributionId":null,"distributionVersion":null,"partnerId":null,"distributor":null,"distributorChannel":null,"partnerNames":[]},"system":{"memoryMB":492,"virtualMaxMB":null,"cpu":{"count":1,"cores":1,"vendor":"GenuineIntel","family":6,"model":8,"stepping":3,"l2cacheKB":null,"l3cacheKB":256,"speedMHz":null,"extensions":["hasMMX","hasSSE"]},"os":{"name":"Linux","version":"4.13.0-16-generic","locale":"en-US"},"hdd":{"profile":{"model":null,"revision":null},"binary":{"model":null,"revision":null},"system":{"model":null,"revision":null}},"gfx":{"D2DEnabled":null,"DWriteEnabled":null,"ContentBackend":"Skia","adapters":[{"description":"VMware, Inc. -- llvmpipe (LLVM 5.0, 128 bits)","vendorID":"VMware, Inc.","deviceID":"llvmpipe (LLVM 5.0, 128 bits)","subsysID":null,"RAM":null,"driver":null,"driverVersion":"3.0 Mesa 17.2.2","driverDate":null,"GPUActive":true}],"monitors":[],"features":{"compositor":"none","gpuProcess":{"status":"unused"}}}},"settings":{"blocklistEnabled":true,"e10sEnabled":true,"e10sMultiProcesses":1,"e10sCohort":"addons-set50allmpc-test","telemetryEnabled":false,"locale":"en-US","update":{"channel":"release","enabled":true,"autoDownload":true},"userPrefs":{"browser.cache.disk.capacity":358400,"browser.newtabpage.enhanced":true},"sandbox":{"effectiveContentProcessLevel":2},"addonCompatibilityCheckEnabled":true,"isDefaultBrowser":null},"profile":{},"experiments":{"clicktoplay-rollout":{"branch":"user-changed-from-test"},"e10sCohort":{"branch":"addons-set50allmpc-test"}}}
Theme: classic/1.0
ThreadIdNameMapping: 1090:"Gecko_IOThread",1091:"Timer",1092:"Link Monitor",1093:"Socket Thread",1094:"JS Watchdog",1100:"Hang Monitor",1106:"Cache2 I/O",1107:"GMPThread",1108:"StreamTrans #1",1109:"SoftwareVsyncThread",1110:"Compositor",1111:"ImgDecoder #1",1112:"ImageIO",1117:"SysProxySetting",1119:"ProxyResolution",1120:"DataStorage",1121:"URL Classifier",1123:"DataStorage",1122:"DNS Resolver #1",1124:"DataStorage",1125:"HTML5 Parser",1126:"IPDL Background",1127:"Classifier Update",1128:"DOM Worker",1132:"ImageBridgeChild",1156:"SaveScripts",1157:"Cache I/O",1158:"mozStorage #1",1159:"mozStorage #2",1161:"mozStorage #4",1162:"mozStorage #5",1163:"mozStorage #6",1165:"DNS Resolver #2",1164:"DNS Resolver #3",1166:"DOM Worker",1168:"SSL Cert #1",1171:"ProcessHangMon",
Throttleable: 1
URL: about:startpage
UptimeTS: 30.910163
Vendor: Mozilla
Version: 56.0
useragent_locale: en-US

This report also contains technical information about the state of the application when it crashed.

If I connect a network cable nothing happens - the computer does not connect to the internet and I do not know how to connect it. The network icon offers no options to connect that I can tell.

Computer had no errors on Memtest86+.

Booting live to liveDVD (try Lubuntu) on a different computer: Firefox does NOT crash when connected to the internet.

I added error code from a single crash from both the command line and the Firefox crash report.

I found another USB WiFi adapter to try and had the same errors and crash.

If I go to the GUI Additional Drivers - no drivers are offered even though I am online.

I am not intentionally running a virtual machine. This was a vanilla default install. How do I check if that virtual machine is running?

Computer had no errors on Memtest86+. Is there a simple command one uses to initiate connecting to the internet once the cable is plugged in or is it automatic?

What to try: Any thoughts? Is it hardware like the wifi adapter or usb itself - two different adapters gives the same crash but USB in the bios settings an issue? Software? Firefox runs just not when connected - it crashes the instant it uses the internet. Firmware? A setting in the bios?

Sorry for any typos and thank your help.

  • 1
    Have you tried Firefox crash troubleshooter support.mozilla.org/en-US/kb/… ? Try running Firefox in safe-mode. – joshas Nov 3 '17 at 19:40
  • Do GUI programs that do not access the internet work, for example leafpad and gnumeric and Disks alias gnome-disks ? - and yes, please edit your original question to include the crash information. Indent each line 4 spaces to render it as 'code'. You can also start Firefox from a terminal window with the command firefox. Look for warnings and error output to the command line and if you find something, add it to your original question (rendered as 'code'). – sudodus Nov 4 '17 at 20:35
  • Firefox works for me in Lubuntu (all versions live and installed). Does it work, when you 'Try Lubuntu' alias boot live from USB or DVD)? In this particular computer? In some other computer (that you might borrow to try live)? – sudodus Nov 4 '17 at 20:47
  • "Is it hardware like the wifi adapter or usb? Software?" I suspect hardware, but I am not sure. Maybe RAM - to be tested with memtest (started from the grub menu in BIOS mode). Maybe wifi (could be both hardware and driver) - maybe your wifi works better, if you can find a suitable proprietary driver. Can you try to connect via wired internet (an ethernet cable)? – sudodus Nov 14 '17 at 6:22
  • 1
    0. Are you running in a vmware virtual machine?; 1. Maybe RAM - to be tested with memtest; 2. Maybe wifi - Can you try to connect via wired internet (an ethernet cable) instead of via wifi? – sudodus Nov 17 '17 at 6:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.