1

I have recently updated my Ubuntu to 17.10. After the upgrade, my keyboard is acting strange. If I select my default keyboard layout (Portuguese Brazil), for every key I type in, the active window freezes for 4 to 6 seconds, and afterwards the typed character is shown. The same issue happens If I have portuguese (Brazil) on my keyboard layout list, even if it's not activated.

If I set the input layout to English (US) and remove everything else, it works, but nos as smoothly as it should be. I still can see some delays between key presses, and it`s kinda annoying use a keyboard layout different from my regional one.

I've also tested with an external USB keyboard (with US layout), and the issue persists.

My current configuration is:

System:    Kernel: 4.13.0-16-generic x86_64 bits: 64
           Desktop: Gnome 3.26.1 Distro: Ubuntu 17.10
Machine:   Device: laptop System: Avell High Performance product: 1513
           Mobo: N/A model: N/A serial: N/A
           UEFI: American Megatrends v: N.1.00 date: 12/27/2016
Battery    BAT0: charge: 44.3 Wh 100.0% condition: 44.3/47.5 Wh (93%)
CPU:       Quad core Intel Core i5-7300HQ (-MCP-) cache: 6144 KB
           clock speeds: max: 3500 MHz 1: 2500 MHz 2: 2500 MHz 3: 2500 MHz
           4: 2500 MHz
Graphics:  Card-1: Intel Device 591b
           Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile]
           Display Server: x11 (X.Org 1.19.5 ) drivers: modesetting,nvidia
           Resolution: 1920x1080@60.02hz
           OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2
           version: 4.5.0 NVIDIA 384.90
Audio:     Card Intel Device a171 driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.13.0-16-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet
           driver: r8169
           IF: enp2s0 state: up speed: 100 Mbps duplex: full
           mac: b0:25:aa:1f:c7:db
           Card-2: Intel Wireless 8265 / 8275 driver: iwlwifi
           IF: wlp3s0 state: down mac: 00:28:f8:0f:80:39
Drives:    HDD Total Size: 2165.5GB (3.1% used)
           ID-1: /dev/sda model: TOSHIBA_MQ02ABD1 size: 1000.2GB
           ID-2: /dev/sdb model: Crucial_CT525MX3 size: 525.1GB
           ID-3: USB /dev/sdc model: S2_Portable size: 640.1GB
Partition: ID-1: / size: 916G used: 6.4G (1%) fs: ext4 dev: /dev/sda2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 61.5C mobo: N/A gpu: 43C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 205 Uptime: 26 min Memory: 1725.6/15965.0MB
           Client: Shell (bash) inxi: 2.3.37 

Is there anything ele I should test before reporting the issue? Any help would be appreciated :)

1

I had the same problem some days ago. Someone told me in private that you have the ^@ character printed every second on tty. That's a known bug in the peaq-wmi driver. Blacklist it and reboot.

  • I was about to close the thread because I did exactly that haha! Thanks :) – Matheus Ferreira Oct 25 '17 at 0:06
  • I am having this problem. How does one exactly disable the driver?? – rainer Mar 30 '18 at 15:48
  • Depends on your system. In my system I created the file /etc/modprobe.d/nowmi.conf with the contents blacklist peaq-wmi – YuriAlbuquerque Apr 3 '18 at 16:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.