1

I recently upgraded to Ubuntu 17.10/GNOME 3.26. Had some glitches during the transition to GNOME from Unity, as I previously partly had used Ubuntu-GNOME as well, and some extensions were killing each other, ubuntu-dock was not working etc.

I got that right, but can not solve another problem which was introduced with a bug with 14.04 - a bogus monitor I have since then: My system settings show a monitor that does not really exist, due to my nvidia optimus BIOS which seems to be announcing a VGA monitor. In the past Ubuntu versions, I could use gnome-control-center to just "switch off" this monitor - but as hard as I try, I can not find any button or switch to kill that damn monitor:

enter image description here enter image description here

Did I miss something here comepletely? Or is it possible that GNOME 3.26 does not provide a tool to disable a monitor?!

Thanks in advance.

  • I think this has nothing to do with Nvidia (as stated in the title and tags on this question at the time of writing). On my system I recently switched from GNOME 3.16 to GNOME 3.26, and at the same time was switching between 2 very different Radeon cards and both had this very same problem but only on GNOME 3.26. At first I thought this was some Wayland problem, but I tried running GNOME 3.26 with Xorg11 and the option was still missing. Seems to be a limitation either of GNOME 3.26 or how it is configured for Debian 9 and its derivatives – ossbuntu Feb 17 '18 at 15:30
0

Seems to have been a mistake in the GUI design of GNOME 3.26

Luckily there's an extension on the way that fixes this: https://extensions.gnome.org/extension/897/turn-off-display/

  • Switched to KDE. Can't test that ATM. – nerdoc Feb 18 '18 at 19:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.