1

I'm trying to disable the touchscreen on my Dell Inspiron laptop (Ubuntu 17.10) as it's faulty. I have a few times been able to do this with xinput disable 9 or xinput disable "ELAN touchscreen". putting these into /etc/profile.d user script, or starting a terminal right away and typing it in, but now that's stopped working since I tried a different fix based around disabling libinput inside /usr/share/X11/xorg.conf.d/40-libinput.conf.

Once or twice it booted and worked (then giving an error on log-in that it couldn't find "ELAN Touchscreen" to disable it) but haven't managed to replicate and the touchscreen frequently crashes.

Here's the two different outputs of xinput I get intermittently (when "ELAN Touchscreen" is listed I can disable it with xinput --disable; in the other case, I have no idea what to do to disable it, as it either messes my session up from the touchscreen's issues, or just crashes and logs me out when I actually touch the screen).

I like it when it looks like this

This is hard to deal with

Update: it worked again this time; like the last time it worked, I waited about 5 seconds on the Ubuntu "select boot option" screen (where it lists 3 options: Ubuntu, some other Ubuntu option, or lets you go to BIOS config, and lets you edit boot commands before startup). When I hit Ubuntu immediately or wait too long the touchscreen remains enabled, so seems there's some weird sweet spot where something's loaded but something else hasn't... so I'm definitely thinking this is a bug in one of these layers.

  • 1
    I just want to confirm I'm having the exactly the same issue on an Inspiron laptop. If anyone finds a permanent solution, I and probably others would much appreciate. – patstuart Oct 31 '17 at 2:50
  • @patstuart my current "fix" is selecting Ubuntu at the right time in the boot menu (when it says "Ubuntu will automatically start in 6 seconds" seems like the sweet spot) and not turning my laptop off for as long as possible – Oliv Utilo Oct 31 '17 at 12:08
  • I'm having the same issue on my Dell XPS 13 running Ubuntu 17.10, with a cracked touch screen. I can disable the touch driver on Windows without issue. I'll try booting as described, but a fix would be nice. Im planning on upgrading to 18.04 LTS in a few days. maybe that will fix it... – Andrew W. Apr 24 '18 at 0:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.