0

I've been searching all over the internet for a solution. I have installed Kubuntu 16.04 and my wifi adapter ir a RTL8188CE. My problem is that I can't configure an access point with WPA & WPA2 Personal security, it connects fine, but when I'm going to connect my android phone gives me an Incorrect Password error each time I've tried. Then I changed the security type to WEP 40/128 bits and all works well.

I first tried to fix it by installing a different driver than the one from the repository as described here in one of the comments: Wifi Connectivity problems when using WPA/WPA2 Encryption

And I used this instead: https://github.com/FreedomBen/rtl8188ce-linux-driver/

But didn't work, the wifi keeps doing the same thing.

Any thoughts?

  • Avoid any WPA/WPA2 mixed mode and TKIP. – user692175 Oct 24 '17 at 19:02
  • Sorry, I don't know much of wifi security standards. May I ask why? – PROW Oct 24 '17 at 20:52
  • Because some Linux drivers for some WiFi chipsets don't like it. And the experts recommendation is WPA2-AES only anyway, for any device / any OS. – user692175 Oct 24 '17 at 21:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.